Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
Visitor
Posts: 1
Registered: ‎11-18-2012
My Device: Blackberry 10
My Carrier: Airtel

Unable to port my android application to blackberry 10

Hi There,

 

anyone help me on this i am unable to port my application to blackberry 10.

 

it was successfully working in android and it was installed in my device but it was showing initialising please wait message on blackberry 10 device in my error logs i found this message 

 

org.osgi.framework.BundleException: State change in progress for bundle "reference:fileSmiley Tonguelugins/com.android.ide.eclipse.adt_16.0.1.v201112150204-238534.jar" by thread "Worker-4".
at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1077)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:282)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:417)
at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:265)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:106)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:453)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:393)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:469)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)

 

Can you please help me on this to found a solution that it works on bb10.

 

Thank you,

 

Regards,

Berrie Cool Designs.

Visitor
Posts: 1
Registered: ‎11-25-2012
My Device: PlayBook 16 GB
My Carrier: N/A

Re: Unable to port my android application to blackberry 10

Try cleaning the project , in eclipse select Project > Clean ... after that try and run the project again.
Developer
Posts: 34
Registered: ‎02-04-2012
My Device: BlackBerry PlayBook
My Carrier: T-Mobile

Re: Unable to port my android application to blackberry 10

Also if you are using eclipse you should verify the apdk in case there critical errors. You can do it doing right click on your project-> blackberry tools -> verify apk

 

Remeber that Android runtime does not support everything Android has this is a link of what it is supported as of today:

http://goo.gl/aNhJ2

 

Hope it helps you.

Visitor
Posts: 1
Registered: ‎06-02-2014
My Device: z10
My Carrier: glo

Re: Unable to port my android application to blackberry 10

Did you install es explorer and Google play on z10? I had the same initialising problem with installing games. I deleted both es explorer and Google play, restarted and the problems have gone. I think android tries to connect to Google play and es explorer before it can install