Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Highlighted
New Contributor
Posts: 8
Registered: ‎12-28-2012
My Device: Playbook
My Carrier: n/a

blackberry-connect thinks my key isn't 4096 bits

[ Edited ]

I've generated an SSH key specifically for blackberry-connect.

 

$ ssh-keygen -t rsa -b 4096 -C "test@example.com"

...

Enter file in which to save the key (/Users/chrisseaton/.ssh/id_rsa): /Users/chrisseaton/.ssh/test@example.com

...

 

When I try to use this with blackberry-connect I'm told it's not long enough.

 

$ blackberry-connect 192.168.1.74 -password whenthegatesfell -sshPublicKey ~/.ssh/test\@example.com.pub 

Info: Connecting to target 192.168.1.74:4455
Info: Authenticating with target 192.168.1.74:4455
Info: Encryption parameters verified
Info: Authenticating with target credentials.
Info: Successfully authenticated with target credentials.
Info: Sending ssh key to target 192.168.1.74:4455
Error: Connection refused: Provided ssh key is too small (4096-bit minimum).
Error: Unable to send ssh key to target

 

Version 1.2.0, on OS X.

 

I'm using blackberry-connect because I want to use adb and logcat to debug a problem.

 

What am I doing wrong?

Regular Contributor
Posts: 51
Registered: ‎06-29-2011
My Device: Z10 Limited Edition
My Carrier: Ukraine GSM

Re: blackberry-connect thinks my key isn't 4096 bits

Same problem, looking for an answer...
New Contributor
Posts: 4
Registered: ‎11-13-2012
My Device: 10 dev alpha
My Carrier: 3

Re: blackberry-connect thinks my key isn't 4096 bits

use parameter -b 4096 

ex: ssh-keygen -t rsa -C "rischanlab@gmail.com" -b 4096

 

New Contributor
Posts: 8
Registered: ‎12-28-2012
My Device: Playbook
My Carrier: n/a

Re: blackberry-connect thinks my key isn't 4096 bits

Not sure what you mean - in my post I said that I used that parameter when generating the key. What are you suggesting I do differently?

New Contributor
Posts: 4
Registered: ‎11-13-2012
My Device: 10 dev alpha
My Carrier: 3

Re: blackberry-connect thinks my key isn't 4096 bits

i got the same problem with you, but this solution worked. https://gist.github.com/diorahman/4334311

my device is BB10 dev alpha 

 

maybe you can try again, backup your .ssh folder and generate new key :-D