Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

Reply
Developer
Posts: 91
Registered: ‎04-05-2013
My Device: Simulator - developer
My Carrier: No provider

'@' character (called "monkey" or "at") not displaying on Q10 in a "textEmailAddress" type of EditText field

In a "textEmailAddress" form field, that lifts the "email" keyboard on Android, blackberry Q10 fails to display the '@' character. The ALT key is ignored and when the key is pressed, the 'p' character is displayed. Even if I attempt to lift the 'SYM' keybord and select the '@' character there, the character is not displayed in the form, the key press is simply ignored.

 

Is this a general Blackberry Android Runtime problem?

 

The device is BlackBerry Q10 with OS version 10.2. The problem is not present on the Z10 device; on Z10 the proper "email" soft keyboard is displayed, and the '@' key is displayed as expected.

 

Cordially,

Rok Ruzic

Highlighted
Developer
Posts: 91
Registered: ‎04-05-2013
My Device: Simulator - developer
My Carrier: No provider

Re: '@' character (called "monkey" or "at") not displaying on Q10 in a "textEmailAddress" type of EditText field

This si worse than I first thought. In my entire application both ALT and SHIFT buttons of the hard keyboard stopped functioning, and the application accepts nothing from the soft "SYM" keyboard. In the whole application I can type only lower case letters, that are the primary characters of the hard keyboard.

 

Has anybody else encountered such a problem?