Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Android™ Development

Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎04-24-2012
My Device: Playbook - 16GB
My Carrier: 02

result::failure -4 when deploying

Hi There,

 

I have a playbook running 2.0.1.358

 

Tonight it stopped allowing me to deploy my app from eclipse to the tablet.

 

i have restarted it a number of times with no luck.

 

Actual error

 

Failed to deploy project XXX
Info: Sending request: Install
Info: Action: Install
Info: File size: 473122
Info: Installing ...
Info: Processing 473122 bytes
Info: Progress 50%...
Info: Progress 100%...
actual_dname:Smiley Surprisedrg.touchandgo.wwff.testEBmc5dWnTmvt10dhfDhh7nQ
actual_id::testEBmc5dWnTmvt10dhfDhh7nQ
actual_version::1.0.2.0
result::failure -4

 

Any idea what the issue/resolution may be?

 

Thanks,

 

Stephen

New Contributor
Posts: 2
Registered: ‎04-24-2012
My Device: Playbook - 16GB
My Carrier: 02

Re: result::failure -4 when deploying

Replying to my own issue here, I read on another thread here that someone else succeeded in fixing this by doing a security reset and reload.

 

I tried that and it has worked, but it seems like a major pain in the a$$ to have to resolve the issue this way.

New Developer
Posts: 15
Registered: ‎04-22-2012
My Device: Playbook
My Carrier: Rogers

Re: result::failure -4 when deploying

When the storage space in Playbook is less than 1.5G, the "failure -4" problem would happen when you deploy an app. So please delete some useless files, then it would be fine.

Developer
Posts: 216
Registered: ‎08-23-2012
My Device: Javelin 8900
My Carrier: Axis

Re: result::failure -4 when deploying

try to restart your playbook, and deploy again..