Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® 10 Desktop Software

Reply
New Developer
Posts: 8
Registered: ‎12-24-2013
My Device: BlackBerry Z10 STL100-3 OS Version 10.3.2.2639 (BlackBerry Link/Blend MS Windows 7 x64)
Accepted Solution

BB Link 1.2.2.13: Z10 is shown "connected" on USB, not via Wi-Fi

Windows 7 Ultimate x64, all current patches, Microsoft standard Windows 7 firewall with the rules installed by BB Link 1.2.2.13; no anti-virus (just MS Windows Defender and MS Enhanced Mitigation Experience Toolkit 4.1). PC user account is regular user, not administartive.

 

BB Z10 10.2.0.1803. (New first-time BB user.)

 

Both devices on same home Wi-Fi subnet, DHCP assigned IPv4 addresses in 10.x.x.x space. "Refresh Devices" on BB Link shows correct Z10 named device.

 

Problem: BB Link installed first time worked over USB and Wi-Fi, i.e. device was shown as "connected" in BB Link after I had set up the USB link, I was able to browse Z10 volumes on PC, and PC folders shared in BB Link appeared in BB Z10 file manager even when the USB cable was removed.

 

However, this didn't last more than a couple of days (I keep Wi-Fi up on both phone and PC, latter gets switched on and off several times a day), but somehow I managed after struggle reestablish the Wi-Fi connection in both directions between the two devices several times. No consistent recipe found however, just dumb luck.

 

But now browsing (and syncing folders/music/etc.) only works PC-->Z10 and *only* when USB connected, BB Link shows Z10 disconnected when not USB connected; also shared folders are no longer shown under PC name in Z10 file manager when USB connected!

 

Tried BB Link uninstall, reboot, delete all BB Link config folders, reboot, reinstall BB Link, reboot, log into BB ID on BB Link, configure USB access to device, reboot, try Wi-Fi access to device from PC: no luck, browsing only works PC-->Z10.

 

Can anyone help sort this out? (I've never used BBM before--no one among my friends/family uses BB phones--but maybe you can direct message your PIN and we can talk--all PINs will be treated in strictest confidence.)

 

The BB Z10/PC bi-directional file sharing is a really useful feature, I'd like to make it work!

 

 

 

 

 

 

 

 

I have a BlackBerry, therefore I exist.
Forums Veteran I
Posts: 1,961
Registered: ‎11-01-2013
My Device: Z30, Z10 (10.3.2.2876), 9860 (7.1), Samsung S4
My Carrier: Indosat

Re: BB Link 1.2.2.13: Z10 is shown "connected" on USB, not via Wi-Fi

Hi insertrealname

 

I have same problem, with Win 8 and Link 1.2.1.31 version. Tried to temporary disable anti virus, restart my router, laptop and Z10 but still failed.

 

It's connected again now after I reboot Z10. When Z10 is powered on, pull the battery out, leave it for 20 minutes and inserted it back. That reboot eliminates glitches in Z10.

 

Good luck.

 

Ps: You need to share your real name if it works Smiley Happy


Click like.jpgto thanks those who help you • If your issue solved, mark the best post in your thread as Solution message_type_solution1.gif


Self Support: Knowledge Base & Manuals

Highlighted
New Developer
Posts: 8
Registered: ‎12-24-2013
My Device: BlackBerry Z10 STL100-3 OS Version 10.3.2.2639 (BlackBerry Link/Blend MS Windows 7 x64)

Re: BB Link 1.2.2.13: Z10 is shown "connected" on USB, not via Wi-Fi

I've tried everything, including taking the battery out for a half hour. The phone never connects to a running instance of BB Link over Wi-Fi, just over USB.

 

I eventually ended up security wiping my Z10 and reinstalling everything from scratch, which solved nothing.

 

It even gets worse than that: in a moment of confusion, I managed to try browsing my PC in the Z10 file manager (unsucccessfully, of course) with a new installation of BB Link running on my PC, but before providing BB Link with my BB ID and doing  the subsequent steps in the setup (connect the device over USB, wait for drivers to successfully install, etc.). I then deleted the Z10 in BB Link when after rebooting both phone and PC, Wi-Fi connectivity continued not to work, uninstalled BB Link for the umpteenth time. The exact sequence of actions is a bit hazy in my mind, but the next time I installed BB Link and went through the sequence of adding the Z10 to BB Link, the Z10's "BB Link" settings now showed 2 PC with the same name! And those 2 PC names in the Z10 BB Link settings survived Z10 reboots, I altered the current advertised PC name in BB Link just to see which of the identical names was the prior BB Link installation's name, and then deleted it from the device. But it returned on the next device reboot, along with the PC name in the currently running BB Link instance. And the two names appeared on the wiped and reinstalled device!

 

So the whole BB Link thing--which had worked so well for a short period (I've only used BB Link for two weeks, the Z10 for 3 weeks total)--is a gigantic failure.

 

The bizarre thing is that things like "Print to Go" do work over the Wi-Fi: the print driver on the PC finds the Z10 and the document appears on the Z10.

 

I'm going to leave the battery out overnight; I have also temporarily disabled IPv6 auto-configured addressing on my Wi-Fi lan's router as well as the dual-stack IPv4/6 Internet access connectivity provided by the ISP.

 

This whole BB Link thing is strange--did the engineers at RIM really need to make this weird mixture of mDNS, WebDAV, IP-over-USB just for endusers to manage their devices?!?

 

I have a BlackBerry, therefore I exist.
Forums Veteran I
Posts: 1,961
Registered: ‎11-01-2013
My Device: Z30, Z10 (10.3.2.2876), 9860 (7.1), Samsung S4
My Carrier: Indosat

Re: BB Link 1.2.2.13: Z10 is shown "connected" on USB, not via Wi-Fi

Sorry that the problem still persist.

The rest options to try ( i'm not sure if you had did it or not) :
1. Install BlackBerry Link in another PC which never installed either BB Link or BBDS to find out is BB Link works well there. If in that other PC works, means your recent PC is the problem one.
2. Clean uninstall of Link in your recent PC.
3. PC System restore into the date that your Link was fine (I did it once and solved the problem) .
4. Factory reset.

If still fail, you can contact BlackBerry support at http://helpblog.blackberry.com/ to obtain formal support. Forums Guru's are welcome for another guidance. Thanks.

Click like.jpgto thanks those who help you • If your issue solved, mark the best post in your thread as Solution message_type_solution1.gif


Self Support: Knowledge Base & Manuals

New Developer
Posts: 8
Registered: ‎12-24-2013
My Device: BlackBerry Z10 STL100-3 OS Version 10.3.2.2639 (BlackBerry Link/Blend MS Windows 7 x64)

Re: BB Link 1.2.2.13: Z10 is shown "connected" on USB, not via Wi-Fi

I did 2 and 3 last week, and I reverted to an old wireless router that only provides local IPv4 DHCP network addressing (the network adapters on Windows 7 all enable IPv6 addressing by default, even if it's just the link-local variety). I even stopped using the Nokia branded micro-USB data cable and use a generic micro-USB data cable (although the Nokia cable has worked normally for plenty of other USB data devices--no special drivers installed). Bizarrely enough, the USB cable Blackberry included with the Z10 is not a data cable, only a charging cable: no Blackberry drivers are installed when a Z10 is connected with it to my PC, while the Nokia and generic data cables cause all the usual Blackberry device drivers to auto-magically install.

I've just attempted an install of BB link on the "cleaned" PC, and everything seems to work: the Wi-Fi link in both directions worked before I connected with the USB cable to backup the device (I still have to test sync, but I doubt there'll be problems).

So thank you everyone for the help! I hope this happy state of affairs lasts.
I have a BlackBerry, therefore I exist.