Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® 10 Desktop Software

Reply
New Member
Posts: 1
Registered: ‎02-13-2014
My Device: Q10
My Carrier: 3107397979

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

Same problem.  Any solution?

Highlighted
Contributor
Posts: 49
Registered: ‎05-24-2013
My Device: Z10
My Carrier: Verizon

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

I was forced to reinstall Link to switch from a bad Z10 to a new replacement Z10. The helper agent still uses more resources than it should, but it is not using 100% again. However now bblaunchagent.app is not responding and I can't seem to kill it. it is also taking system resources.

Recommendation: Install Link, do your business, then uninstall it.

Note: I had to call tech support to get it completely uninstalled last time. You know something bad is happening when a Mac application says you have to restart the computer to use it. I haven't uninstalled it this time because I'm not sure that I'm gonna keep this Z10 either.
New Member
Posts: 1
Registered: ‎09-14-2014
My Device: Z10
My Carrier: Vodafone

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

PLEASE CAN YOU TELL ME WHY I HAVE SPENT MANY HOURS TRYING TO REMOVE BLACKBERRY LINK HELPER AGENT ON MY MAC BOOK PRO

I HAVE UNINSTALLED THE SOFTWARE

I HAVE DELETED ALL RELEVANT LIBRARY FILES

EVERY TIME IT RESTARTS

Forums Veteran I
Posts: 2,790
Registered: ‎10-26-2013
My Device: BB

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

https://discussions.apple.com/message/22482611#22482611

 

There are some solutions that might work for the users here.

New Member
Posts: 1
Registered: ‎10-08-2014
My Device: Z10
My Carrier: Vodafone

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

Hi Guys,

 

I have the same problem.

 

What I have done to kill "BlackBerry-Link-Helper-Agent" through Terminal with this step:

 

Open Terminal on OSX.

 

$ launchctl list | grep blackberry

 

In my case it showed:

349 - com.rim.blackberrylink.BlackBerry-Link-Helper-Agent

 

$ launchctl remove com.rim.blackberrylink.BlackBerry-Link-Helper-Agent

 

Probably it will ask you Administrator permission, then do like this:

$ sudo launchctl remove com.rim.blackberrylink.BlackBerry-Link-Helper-Agent

Password: <Your Admin Password>

 

Hope it will help!

 

Have fun.

 

Cheers.

- e r g - 

Forums Veteran I
Posts: 2,790
Registered: ‎10-26-2013
My Device: BB

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

Thanks for the feedback.

 

New Member
Posts: 2
Registered: ‎04-10-2015
My Device: Z10
My Carrier: Airtel

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

I had the same problem. The files are hidden that you have to delete. If it appears again, (which happened in my case) then it means that this agent creates a demon in the root file, and every time you delete, it immediately creates a new set of files. You can get an expert on Mac to get it removed permanently using the "Terminal".
New Member
Posts: 2
Registered: ‎04-10-2015
My Device: Z10
My Carrier: Airtel

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

I had the same problem. The files are hidden that you have to delete. If it appears again, (which happened in my case) then it means that this agent creates a demon in the root file, and every time you delete, it immediately creates a new set of files. You can get an expert on Mac to get it removed permanently using the "Terminal".

New Contributor
Posts: 6
Registered: ‎11-16-2009
My Device: Not Specified

Re: BlackBerry-Link-Helper-Agent running 100% on OS X

Hey This is great. It works but I have to do this everytime I restart my Mac. In fact I don't even use Blaberry any more. 

 

Is there a way to make this more permanent?

 

Cheers