Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® 10 Desktop Software

Posts: 21
Registered: ‎05-21-2013
My Device: BlackBerry Z10
My Carrier: Rogers Wireless

BlackBerry Link Win7 64bit and VMWare Fusion 5 on OSX ML



I've already tried searching and found nothing even related to VMWare Fusion 5. 


I have a Mac Mini, 2012 running OS X 10.8 Moutain Lion - it shipped with this so I cannot roll backwards. Although I have BlackBerry Link for OSX installed and running perfectly, many of you know that BlackBerry still refuses users to install BB10 (like the previous legacy BBs) using desktop software for OSX. 


I've played with the BB 10.1 leaked software (1762 I believe) and felft is was time to go to the officially released 10.1 from Rogers Wireless after the BlackBerry Live 2013 announcement. After a backup using my Mac's BBLink ... and installing Rogers' 10.1 ... I cannot restore, not even a partial restore from any one of my backups since using that leaked software. 


disclaimer: I know leaked and unofficial software is NOT supported by BlackBerry - I'm not asking for that. 


Here is my setup: 

Mac OS X Lion 10.8.3

2.3Ghz Intel Core i7 (Quad-Core) Late-2012 model

this model features the USB3.0 ports. 


VMWare Fusion 5 (I've already tried Parallels 8 with the same issues)

Win7 64-bit Enterprise SP1 with all drivers installed ... 


Issue: Device manager reports RIM Network or RIM device that will not install the USB drivers. Very fustrating because neither Parallels support for v8/7/6 nor VMWare support have anything remotely related. Their generic support points to me shutting down the VM, and changing the network connection or routing the USB connection to the VM automatically. I've done this to no solution. 


Fusion 5 uniquelly allows me to "remove" the USB controller and/or set the USB to USB1/2/3.0 Support. Changing to USB1 doesn't resolve, USB3 causes my VM to fail for even starting ... I can't even get to see the efi boot let alone the Win7 scrollbar boot critters. I just want to be able to connect my Z10 via my VM so that I can go about my own support back to a leaked 10.1. 


I've connected my Z10 directly to any of my available 3 out of 4 USB3 ports, even the 4th one removed, and the 4th reconnected to my Dell 19" LCD since it has a USB2 hub within. 


Reason: I'd like to get back my applications, the settings, my MMS & SMS to current and not have to loose those important communications and settings. I regret being chosen as a test mule for anything BB10 possible before the company I work for rolls this out beyond the executives. 


NOTE: BB10 no longer (official or leaked in 10.1) allows a user to keep SMS on SIM card, a very bad move BlackBerry. 



Can anyone help please? Pretty Please?!

Posts: 21
Registered: ‎05-21-2013
My Device: BlackBerry Z10
My Carrier: Rogers Wireless

Re: BlackBerry Link Win7 64bit and VMWare Fusion 5 on OSX ML

36 Views  ... any nobody running VMWare Fusion 5 on a OSX Lion or Mountain Lion has anything I can try? I doubt Windows users are looking since its a VMWare Fusion on OSX in my tags ... but I'm welcome to entertain any Windows troubleshooting I've missed. 


update ... I've tried asking for BlackBerryHelp on Twitter - standard reply "please contact your service provider" ... yeah right like Rogers Wireless would know anything about Fusion 5. 


What I've done thus far since my original post. 


1. Close all Blackberry Software

2. Add/Remove Desktop Manager (and MediaSync if you have it installed seperate)

3. Delete registry folders (type REGEDIT in the smartsearch field)


-HKEY_CURRENT_USER\Software\Research in Motion

-HKEY_LOCAL_MACHINE\Software\Research in Motion


4. Delete Research In Motion Folders from C:\Program Files\Common Files and from C:\Program Files\

5. Delete Research in Motion Files from C:/Users/username/appdata (if it's in there, most likely it wont be. If you cant see APPDATA, make sure you are viewing hidden files)

6. Copy paste this poste and save it in notepad because you need to reboot and do another step

7. Reboot

- removed EVERY instance of Parallels in the Registry, Program files (x86) folder, AppData/Local folder (no other AppData listing), msconfig (nothing listed), removed from Common Files folder in Program Files (x86), removed even files related to it from the root of C:\ . I've done the same for BlackBerry Link, Research In Motion, RIM all GONE. 

8. Rebooted, and Rebooted one more time, d/l the new BlackBerry Link, install, same thing ... no drivers can be installed for Z10.


Note that the Z10 is recognized by Windows 7 64-bit Enterprise in my VMWare Fusion 5 ... but it will not install ANY drivers for it. Windows Update finds no driver at all. I see 2 folders where BBLink has drivers in Program Files (x86)/Common Files ... but nothing works for my Z10. 


And for the record VMWare Tools are installed correctly ... I've even tried uninstalling then re-installing them and ensured no pending updates where awaiting. Still no resolution. 


I'm almost about to loose my mind and destroy this VM of Windows and start all over again! 

Before I do  ... is there anyway to invoke Z10's internal file for BBLink to be installed ... and does 10.1 install Link 1.1 or Link 1.0? 


Thank you and any help would be most appreciated.