Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® 10 Desktop Software

New Member
Posts: 1
Registered: ‎08-19-2013
My Device: Q10
My Carrier: 1010

Blackberry Link Crashes on Vista with Q10

Have tried everything possible.

i did a partial sync the first time only, now will crash with out even connecting to device.

Reinstalled the softwear which is

Still no only runs around 30sec before crashing.


Please help, kind of worried when I cant sync for such an extended time.


I see other people have sync issues but no one mentions link just triaght our crashing?


anyone for ideas thanks?



Posts: 3,198
Registered: ‎01-27-2010
My Device: BlackBerry Z10

Re: Blackberry Link Crashes on Vista with Q10

Hi thinksideways and welcome to the BlackBerry Support Community Forums!


There is a new version of BlackBerry Link available. I would recommend uninstalling your current version, then install the new version from https://swdownloads.blackberry.com/Downloads/contactFormPreload.do?code=A8BAA56554F96369AB93E4F3BB06...






Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

Regular Contributor
Posts: 53
Registered: ‎11-20-2012
My Device: Q10
My Carrier: AT&T

Re: Blackberry Link Crashes on Vista with Q10


I have never had a problem with Link recognizing my Q10, til this week.  I have the version installed and rebooted PC and retried.   Link says I do not have a 10OS phone???  It always use to back up at weekly intervals.


I use the original USB cord from Blackberry, so no variance there.  I ran a quick check on the 4 USB ports and all are live and viable.  Checking the cord viability, it is great on the meter.  PC has no problems. 


Would it be best to remove the current Link and reinstall?  It appears that Link has morphed into something that can't recognize the Q10.  The only option presented is "remove this device" 


Any help appreciated.


Thanks in advance-