Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® 10 Desktop Software

Reply
Highlighted
Visitor
Posts: 1
Registered: ‎08-07-2014
My Device: z10
My Carrier: fido

I need Blackberry Link for OSX 10.6.8

I do not want to upgrade my mac to mavericks because it apparently has speed issues. How can I get the old version of blackberry link for my z10 so it works with OS 10.6.8.

Forums Veteran I
Posts: 2,790
Registered: ‎10-26-2013
My Device: BB

Re: I need Blackberry Link for OSX 10.6.8

The only way to get a older version of BB Link is from someone who saved the installer.

 

Replying to you on 10.9.4 and yes it has speed issues and freezes often, especially iPhoto, also when multiple apps are open.

 

I like my Mac Book Pro, fully loaded, way over priced, and over hyped.

 

The only thing Apple does good is marketing.

 

Never had these issues on a PC, not even Vista.

 

Just ordered a Dell Precision, six times better processor than the one I paid $200 more for from Apple who claims to install the best Intel processors (special order, only available on line not in store, ships from China) 

 

Apple does put the best processor, another marketing trick, it is the best of the ordinary ones, Dell puts the best of the extreme processors. Plus I get 2 hard drives and a removeable battery and much more.

 

Very disappointed in Apple, at least like you I have a BB phone and not a iPhone.

 

 

New Contributor
Posts: 2
Registered: ‎09-22-2014
My Device: Q10, 9900, 9790, 8880
My Carrier: Mobistar ( Belgium)

Re: I need Blackberry Link for OSX 10.6.8

Sad to notice how unhelpfull the reply in this forum proves to be.

 

the Q10 is my 5th BB in a row (previous : 9900, 9790, 8520, 8800)

 

And now in your infinte wisdom you oblige OSX users to upgrade from 10.6.8 to 10.7 and up.

I'm perfecrly happy with 10.6 and apple updates always have suprises such as software/hardware that suddenly becomes obselete. You can undestand i'm not willing to update OSX "just" to use my phone, not even a BB!

 

Instead of replying : go find someone with an "old" installer, you could make te effort to supply such.

 

It may have escaped your attention but BB is not as popular as it used to be.

You could be inclined to nurture somewhat your clientbasis ...

 

Untill now i still pay 10 € for the BB service.

The Q10 could save me 120 € / year ... or a new phone every 2-years.

 

At the time being i consider using an iPhone (we hae a spare iPhone 4 hanging around) or follow my youngest son on samsung S in selling my brandnew Q10.

 

I'm very curious to read your reply and any creative solution implied in it.

 

regards

carl

Forums Veteran I
Posts: 2,790
Registered: ‎10-26-2013
My Device: BB

Re: I need Blackberry Link for OSX 10.6.8

[ Edited ]

We are all volunteers here and have no connection to Blackberry, just trying to help out our fellow humans the best we can.

 

We give up our free time and resources and get nothing in return except sometimes a THANK YOU ! and sometimes CRITICISM !

 

We can only supply info that is available to us and if Blackberry chooses not to supply historical versions of their software that is their right.

 

There is limited software publishers such as Adobe that do supply historical versions but that is a different matter.

New Contributor
Posts: 2
Registered: ‎09-22-2014
My Device: Q10, 9900, 9790, 8880
My Carrier: Mobistar ( Belgium)

Re: I need Blackberry Link for OSX 10.6.8

OK sorry, did not know about you voluntering.

 

Still my argument remains

 

regards

carl

Forums Veteran I
Posts: 2,790
Registered: ‎10-26-2013
My Device: BB

Re: I need Blackberry Link for OSX 10.6.8

I understand your view and I do wish more software publishers would keep historical versions.

 

I learned a long time ago to keep all Installers I downloaded in a special file and on three different hard drives.

 

I have installers dating back ten years and used many times over and still can be used, and by accident only lost one, and some of these installers can no longer be found on the Web.

 

I use many Adobe historical versions to test flash videos etc.

 

If you read my fisrt post you see I am very unhappy with my Mac also.

 

GOOD LUCK !