Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® 10 Desktop Software

New Member
Posts: 1
Registered: ‎09-25-2013
My Device: Q5
My Carrier: Vodafone

Q5 Restore failure



I did a full backup of my blackberry Q5 using blackberry link, which completed flawlessly.


However, after wiping my device and attempting a full restore, I keep getting error/failure messages. It usually has to do with the connection, as it claims it has been lost (the phone was never moved) or that it can't simply complete the backup.


Once, it popped a message saying there was no "personal space" or something of the like.


I have tried restoring the OS, wiping again (several times in fact), reinstalling BB Link, updating the phone's OS and even attempted to restore using an older version of the OS. I also tried canceling from the phone and restarting the restore process.


As of now I don't have that much data (and I was wise enough to store the pictures elsewhere), so I can start from scratch and reconfigure my bb. However, I am worried that this is a recurring issue and that eventually I might lose important information due to inability to restore.


I'd appreciate any help.


Thank you.

Posts: 4,285
Registered: ‎07-26-2010
My Device: Q10/Q5/Z10/9930/9860/9310

Re: Q5 Restore failure

Hey patriciaoctorresm,

Welcome to the BlackBerry Support Community Forums.


Thanks for the question.


Can you provide the exact error/failure message you're receiving?


Also did you recently update to a later version of BlackBerry Device Software  after you created the backup?


I look forward to your reply.





Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp

Be sure to click Like! for those who have helped you.

Click  Accept as Solution for posts that have solved your issue(s)!

New Contributor
Posts: 2
Registered: ‎10-22-2010
My Device: Not Specified

Re: Q5 Restore failure

Hello the error on the blackberry link is "Can not communicate with the device" Regards