Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Highlighted
New Member
Posts: 1
Registered: ‎02-12-2013
My Device: BB Z10
My Carrier: DU

BB Z10 and BES

I have a BB z 10 and BES 5.0.3. I got to know that this BES version is not compatible with BES 5.0.3 andI need to upgrade to BES 5.0.4. Also BES 5.0.4 will work only withBB Z 10, while all other devices will work only with BES 5.0.3 Anyone can confirm please
Forums Veteran I
Posts: 2,077
Registered: ‎10-10-2010
My Device: Priv
My Carrier: Three UK

Re: BB Z10 and BES

From my understanding you need BES10 to use a BB10 device via BES