Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Contributor
Posts: 6
Registered: ‎02-17-2013
My Device: z10
My Carrier: vodafone

Very poor signal compared to 9800

Ive noticed that the signal is very poor at times on the Z10, the signal was fine on the 9800 i had, I can create an email and it will be sat pending for up to 10 mins before its sends.

Contributor
Posts: 26
Registered: ‎02-07-2013
My Device: Blackberry Z10

Re: Very poor signal compared to 9800

Lets compare apples with apples. Your 9800 was more than likely on a 3G network but Z10 runs on 4GLTE, if available. Make sure you set you Z10 phone on the same settings as 9800 to see if signal is actually less.
Regular Contributor
Posts: 72
Registered: ‎02-06-2010
My Device: Passport SE
My Carrier: Virgin Mobile

Re: Very poor signal compared to 9800

Will agree with scopewizard.  When I first got my Z10, I still had a non-LTE SIM in it and the signal strength was at full bars.  (Interestingly, when I picked up my Z10 at a Virgin Mobile store, they had the iPhone 5, S3, Nexus 4 and the Z10 and the Z10 had the strongest signal even though all phones were on the same network).

 

When I added a LTE SIM card in, the signal strength dropped.

 

There is a good app on Android called 'Open Signal' where you can see which tower you are connecting to and also see coverage maps based on the band.  LTE coverage isn't very good where I am (Otttawa, Ontario) which accounts for the poor signal strength.

 

I am still surprised at how fast browing is though even in 3G (beats any other phone I have tried, even my 'quad core' Nexus 4) so I could live in 3G and be quite happy.

Highlighted
New Contributor
Posts: 6
Registered: ‎04-17-2013
My Device: 9900 Z10
My Carrier: Rogers

Re: Very poor signal compared to 9800

I am see a lot of people having problems with signal strength on the Z10. My Z10 might give me one bar in my building, and but the person besides me using an identical phone on the same network shows full bars. The sound is also crappy