Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Contributor
Posts: 5
Registered: ‎07-03-2013
My Device: z10
My Carrier: Global

Re: Z10 battery drain while powered off

have the same problem

New Member
Posts: 185
Registered: ‎06-06-2011
My Device: Torch 9800 / PlayBook / Z10 / Passport
My Carrier: O2 UK

Re: Z10 battery drain while powered off

[ Edited ]

 Z10 OS 10.1.0.4200.

 

I recently left my phone switched off for a week. Before I did this I  made sure there were no alarms or calendar reminders set and switched off my Z10  which at this point was fully charged. When I returned 7 days later and tried to turn on my Z10 the battery was dead, no charge whatsoever.  This happened once before with a previous OS but was surprised it happened this time after taking the precautions mentioned above. Any ideas why this is happening?  

 

Alongside my Z10 was my 4 year old Nokia E66 which guess what,  lost no battery charge whilst turned off for a week. Other phones such as my old Torch 9800 would also  hold its charge when given a well earned rest. Are BlackBerry aware that the Z10 has battery issues?  Are they addressing this in future updates?  Any advice on this would be much appreciated.  

BlackBerry is for Life, not just for Christmas
New Member
Posts: 185
Registered: ‎06-06-2011
My Device: Torch 9800 / PlayBook / Z10 / Passport
My Carrier: O2 UK

Re: Z10 battery drain while powered off

Anyone?  

BlackBerry is for Life, not just for Christmas
New Contributor
Posts: 5
Registered: ‎07-03-2013
My Device: z10
My Carrier: Global

Re: Z10 battery drain while powered off

I would guess that your problem happened cause every electric device has some systems running in background although you have switch it off.
An example of that a clock time in your device or a computer. You turn off the device and turn it back on you find that it has the correct time. "Try to remove the battery from your phone for a while and then try to turn off the device you find that it ask you to input the time

This is my guess
New Member
Posts: 185
Registered: ‎06-06-2011
My Device: Torch 9800 / PlayBook / Z10 / Passport
My Carrier: O2 UK

Re: Z10 battery drain while powered off

Thanks for the reply. I will try this. 


jsaleh88 wrote:
I would guess that your problem happened cause every electric device has some systems running in background although you have switch it off.
An example of that a clock time in your device or a computer. You turn off the device and turn it back on you find that it has the correct time. "Try to remove the battery from your phone for a while and then try to turn off the device you find that it ask you to input the time

This is my guess

 

BlackBerry is for Life, not just for Christmas
Highlighted
New Contributor
Posts: 3
Registered: ‎11-12-2011
My Device: Curve 9360
My Carrier: Orange

Re: Z10 battery drain while powered off

Well I don't really want to tell you this but this occurred in a new Z10 that I upgraded to and Orange had to replace it.  The phone literally died and would do nothing.

New Contributor
Posts: 4
Registered: ‎12-28-2013
My Device: z10
My Carrier: Globe Telecom

Re: Z10 battery drain while powered off

Why cant the BB team fix this....grrrrr....! We need an update to fix this glitch.
New Contributor
Posts: 4
Registered: ‎12-28-2013
My Device: z10
My Carrier: Globe Telecom

Re: Z10 battery drain while powered off

I think its with the software....as many are complaining about this problem.
Developer
Posts: 1,251
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: Z10 battery drain while powered off

I have the same problem.  I have the latest 10.2.x developer release OS on my Z10 and after a few days of having it powered completely off after topping off the battery, the next time I power it up I have maybe 10% charge left.

Developer
Posts: 1,251
Registered: ‎12-29-2010
My Device: PlayBook, Z10 LE, Dev Alpha C

Re: Z10 battery drain while powered off

[ Edited ]

More data ...

 

I fully charged and then removed from the phone the same battery (I only have one Z10 battery at the moment) that had been losing its charge while installed in my powered-down Z10, and left it out of the phone for a week.

 

On putting it back in the phone and powering up, it still has 100% charge.  It appears that the battery itself is fine, but when installed in a powered-down Z10, the battery draws down badly.