Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

New Contributor
Posts: 2
Registered: ‎02-12-2013
My Device: bb z10
My Carrier: viva
Accepted Solution




i already have a bb9800, i registered my new z10 with the same id , but couldnt retrieve the contacts from the old one,, so to create a new id ,, i am asked to do a security wipe , while doing that my phone got off with no battery,


after that when i charge my phone and tried to switch on the phone , the phone is not getting switched back onn,


its a symbol to connect the phone to pc,,, but when i connect my phone to pc it is not getting connected,, i installed the bb link software and bes 10 exe software,,, still cant coneect to pc,,, i tried multiple comps including the mac,,



what should i do,,, how do i reset my phone if its in a stage like this,,, is there any reset options with the external buttons>???????

Elite I
Posts: 6,657
Registered: ‎01-14-2009
My Device: BlackBerry Z10
My Carrier: Telus

Re: hanged

Hi Hashin5858,


You're going to want to follow the instructions in the following KB article:


KB33480 - BlackBerry 10 smartphone does not boot and displays a Phone with USB icon after an interru...


That should get you back up and running!


(Note: If you can't get it to work, make sure the BlackBerry Link software is fully shut down by pressing Ctrl+Alt+Del on your computer, then go to the Task Manager, and under the Processes tab, shut down all BlackBerry related processes).

If you want to thank someone for their comment, do so by clicking the Thumbs Up icon.

If your issue is resolved, don't forget to click the Solution button on the resolution!

New Contributor
Posts: 2
Registered: ‎02-12-2013
My Device: bb z10
My Carrier: viva

Re: hanged

successfully worked,, took a lill bit of time,,, but back in action thanx buddy

Posts: 33
Registered: ‎05-04-2013
My Device: Blackberry Q10
My Carrier: Bell

Re: hanged

for other issues with same problem , try another USB port.