Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

New Developer
Posts: 6
Registered: ‎01-12-2010
My Device: Bold
My Carrier: Rogers

Appworld required on Device for BES push

Hi folks,


We have developed an app for another company that is currently available on the Appworld, this company also wanted to deploy this app on their BES.


So we provided the ALX and COD files to them.  The server admin is having an issue where he can only deploy this app on devices that have Appworld already installed on them.


The app was developed using Phonegap in Eclipse 3.5.2 (Galileo) using the BlackBerry Plugin for Eclipse.  Is there a setting that I can disable/enable so that he can deploy on any device?


Thanks in advance.



Regular Contributor
Posts: 62
Registered: ‎05-18-2010
My Device: >300 8530s and 9330's
My Carrier: Verizon, Sprint

Re: Appworld required on Device for BES push



I don't know if this helps you or not, but I just checked and I have Appworld disabled via policy on my BES server and I'm able to push out 3rd party apps non problem.


Only things I can think of would be In the app policy they need to make sure that their app policy set to "required" and make sure they do a "loader.exe /index" or "loader.exe /reindex" after they put the cod and alx on the server. If it still isn't going then check their POLC log and see what is wrong. I don't think it would be your application.



Posts: 10
Registered: ‎06-30-2010
My Device: Bold 9700
My Carrier: KPN

Re: Appworld required on Device for BES push



The solution is to allow the appworld on the devices and set the restriction on applications.


Best regards,

Ilias el Matani