Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

New Contributor
Posts: 2
Registered: ‎06-28-2011
My Device: Torch 9800
My Carrier: Sasktel

BES 4.1 not working Please Help

Hello All,

I have recently done a complete renovation of my company's server room, which required me to disconnect/reconnect all our servers, back ups, switches and routers. Everything went flawlessly except for this morning I started getting calls that our BES server wasn't working and that no one could send/receive e-mails on their BB's. I logged onto the BES with the BESadmin account, which is being hosted on a VM, and all seems to be running fine. All the services are running, I restarted the VM, and still nothing. I know this has something to do with me disconnecting all the hardware and reconnecting it. I have double and triple checked that everything was connected as it had been originally. I called an IT to come look at it, he has solved some of our BES issues in the past, but he couldn't see why it wasn't working.

I decided to delete my user and try to re-add and re-sync the enterprise activation to my phone to see if it would connect, but when I go to add my user, it says "The number of users selected exceeds the number of available licenses. Please select a fewer number of users to add." This is very odd because it is showing that we have 17 licenses, and 17 are being used - but really, only 14 users are "running" off the BES. It seems as though there is a link broken to the database, and has stopped all e-mail traffic.

Any help is greatly appreciated, our company's salesmen depend on the BES - so this is a serious issue. Please understand that I am an aspiring IT, and the system we are using I did not create, so it becomes difficult to know how things are set up.

Thank you very much.

Guru III
Posts: 32,144
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: BES 4.1 not working Please Help

If user is stuck in pending delete, you can drop user from database using the following:

1. Open command prompt
2. Type "osql -E"
3. 1>use BESMgmt
4. 2>go
5. 1>delete from userconfig where mailboxsmtpaddr=''user@domain.com''
6. 2>go


Click here to Backup the data on your BlackBerry Device! It's important, and FREE!

Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.

SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope

Want to thank me? Buy my KnottyRope App here

BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V

New Contributor
Posts: 2
Registered: ‎06-28-2011
My Device: Torch 9800
My Carrier: Sasktel

Re: BES 4.1 not working Please Help



Thank you very much for your reply, but I beleive this is a bigger problem then just a user stuck pending a delete.


It looks like the BES cannot connect to the SQL because I constantly get the following error when I try to do a change to the BES though CMD Prompt:


[SQL Native Client] Named Pipes Provider: Could not open a connection to SQL Server [2].

[SQL Native Client] An error has occured while establishing a connection to the server. When connecting to SQL server 2005, this failure may be caused by the fact that under the default settings SQL server does not allow remote connections.


If anyone has an answer as to why this error and why our BES stopped working after disconnecting and reconnecting everything, I would very much appreciate any info that you can give me. Thank you very much