Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

New Member
Posts: 4
Registered: ‎04-10-2008
My Device: Not Specified

Cannot activate new user - stuck on 'initializing'


We recently upgraded to BlackBerry Professional Software, and purchased new licenses to accomodate new users within the company.


After the upgrade, I have attempted to add a new user. I generated and emailed an activation password, which the client entered into his device. However, on his device it is stuck on 'connecting to server', and on the BlackBerry manager software, its showing his status as 'initializing'. He can retrieve his private emails on his BlackBerry OK, its just having problems with setting it up with his work email from the BlackBerry server here.


I spoke with BlackBerry support, who advised to call the telephone company (vodafone) which he is with. However I believe this is likely to be an issue with the BlackBerry server.


Can anyone please shed some light on this issue? Any help or guidance would be hugely appreciated.



Posts: 27
Registered: ‎04-04-2008
My Device: Not Specified

Re: Cannot activate new user - stuck on 'initializing'

What have you upgraded from?


Are the permissions set correctly?


After the user presses the 'activate' button on the device and the activation message with the etp.dat attachment appears in the inbox, does it then leave automatically or does it stay there?


Have you managed to activate anyone else?


What mail system are you using? 

BESX 4.1.x Troubleshooter, Administrator and Installer
Neverfail Certified Implementation Engineer
I dabble with a bit of Domino but think it's crap!
RIM Certified Support Professional/Specialist
Regular Contributor
Posts: 96
Registered: ‎04-07-2008
My Device: 9900
My Carrier: Cable & Wireless

Re: Cannot activate new user - stuck on 'initializing'

Firstly, bounce the BES server again and check all services are running fine

Secondly, did you run the HANDHELDCLEANUP.EXE with a switch of -u?


This is done from a CMD prompt and changing to the directory of the tools folder, (C:\Research in Motion\BlackBerry Enterprise Server 4.1.4\tools), the type HANDHELDCLEANUP.EXE -u


Also, make sure your on the latest hotfix for your server.



Posts: 11
Registered: ‎04-01-2008
My Device: Not Specified

Re: Cannot activate new user - stuck on 'initializing'

[ Edited ]

cambo wrote:


I spoke with BlackBerry support, who advised to call the telephone company (vodafone) which he is with.

Hello cambo,
If you spoke with BlackBerry support and they recommended you contact the carrier this would likely due to provisioning. From what you described this a new user who has not been on a BES before but is currently using the BlackBerry Internet Service - that to me would sound like they don't have the BES service class on their provisioning.
You can more or less verify this VERY quickly - just have the user enterprise activate using their own personal email address (such as a yahoo, Google Mail, hotmail account), if within a minute or two the activation message does not show up in their inbox it's very likely they don't have that service class on their account which would prevent them from using any BES or etp service through the wireless networks.
However if that's not the case you're going to want to check the following:
When the user activates against their personal email (yahoo, hotmail, Google Mail) does the activation message show up?
When the user activates against their email associated with the BlackBerry Server does the activation message show up in their inbox?  Make sure it's not going to a personal folder, subfolder, junk mail folder, deleted items etc.
If the activation message is showing up in the inbox and is just sitting there after several minutes you may want to verify the permissions on the BlackBerry Service account, you can refer to the installation guide for instructions on setting these permissions.
These are just a few quick things to check, please let us know the results so we can help you further. 
Message Edited by Beholder on 04-22-2009 10:56 AM
New Member
Posts: 4
Registered: ‎04-10-2008
My Device: Not Specified

Re: Cannot activate new user - stuck on 'initializing'

Firstly, thanks to everyone for your quick replies and assistance with this.


After speaking to the user again, it turns out there was a setting on his device he had not configured (wish we had found this out earlier instead of going to all this effort!). Once he had enabled this (not sure what the setting was, i got this info from another colleague), a new activation password was generated and emailed to the client, and he was able to connect with our server.


We did have other users set up, however this was my first time setting up a new user from scratch, so I will be aware of this in the future.


Once again, thanks for your help guys, hugely appreciated! Smiley Tongue 

Regular Contributor
Posts: 96
Registered: ‎04-07-2008
My Device: 9900
My Carrier: Cable & Wireless

Re: Cannot activate new user - stuck on 'initializing'

By the sound of it he didn't have the Mobile Network enabled.


Main thing is it is sorted out now


New Contributor
Posts: 2
Registered: ‎04-19-2008
My Device: Not Specified

Re: Cannot activate new user - stuck on 'initializing'

Hi Guys,


I'm having a similar problem and wondered is anyone might shed some lights on it.... Here are the details,


BES (this is what it says under Blackberry Manager - assuming this is the version for BES...)

MS SBS Server 2003 (SP2)

Single user only


Has been working OK for about 8 months, when the user's handset (Curve 8300) was damaged beyond repair.

Got replacement handset (Curve 8310 on Vodafone in the UK).  Resent activation e-mail and user attempted activation but no joy.


So deleted the user in Blackberry Manager and re-created.  Resent activation e-mail and still not working (the Blackberry Manager has the user as 'Status: Initializing - activation password set'.


I have tried the sending the activation e-mail to another address and received it there OK so assume that part is OK (and the handset has been used for Internet, SMS and Voice with no problems).


Not sure how I can confirm it is coming into Exchange though.  We are using the POP3 connector and I successfully see a message downloaded and delivered to the mailbo, but don't see anything actually arrive (or leave) the mailbox, but assume it is getting intercepted by the BES??


Let me know if there is any other info that would help troubleshoot. 


All pointers gratefully received!




Paul Kearney


Posts: 121
Registered: ‎03-31-2008
My Device: Not Specified

Re: Cannot activate new user - stuck on 'initializing'

[ Edited ]

Hello Pkearney,


The basic EA troubleshooting would involve a couple of check points.


1. Add user to BlackBerry Manager

 - Check in the application log (hit F5 or Refresh if required) to see messages like
   "User Added to BES" (successfully added user to BlackBerry Enterprise Server and will monitor users mailbox)
   "1 user failed to initialize" (you will be unable to activate that user if this message shows up)

 - This ensures proper permissions set for EA to complete and the mailbox advise session is established


2. Check user is in sufficient wireless coverage

 - Due to different "Themes" developed for BlackBerry devices, reading the number of Bars available is sometimes not accurate, check the "Options - Status" menu for signal strength, anything below

-90dbm (by this I mean -99dbm is worse signal strength as compared to -90dbm) can cause issues during Enterprise Activation


3. Check for the ETP.dat message in users inbox (if it's arriving there is it being modified by a spam filter/AVirus software)

  - If that etp.dat message is not arriving, as recommended above in the thread, try and activating with a hotmail/google mail/yahoo email address to check if the etp.dat email arrives into those email

  - This step ensures device provisioning from your wireless carrier and sufficient wireless coverage atleast to start the EA (if signal strength fluctuates and constantly drops during EA, the

process will stop at different points)


4. Assuming the above 3 criterion are met, I would recommend right clicking choosing "Reload User", which forces a mailbox rescan for the user, during which the etp.dat message should be picked up

to kick start the EA process


5. If the etp.dat email message is sitting in the mailbox and not being picked up, it would be BlackBerry Enterprise Server related


6. If this message never ends up in the mailbox, it could be either due to provisioning or being blocked/lost in transition which would have nothing to do with the BlackBerry Enterprise Server


7. One of the other troubleshooting steps performed from an administrators end to verify if the etp.dat email message is actually arriving and being picked up is as follows
  - Remove User from BlackBerry Manager
  - Ask user to activate from BlackBerry device with their email address and a simple password eg: 'a'
  - Wait for the etp.dat to arrive in their mailbox, since the user does not exist on the BlackBerry Enterprise Server there is no reason this email should not be in the "Inbox"
  - Please ensure this email does not end up in a different folder like "Junk Mail" since the email header at this point is already modified by your mail/spam filters for BlackBerry Server to

realize this is the activation email

  - If the message arrives, at this point you can go ahead and add the user to the BlackBerry Manager, set their EA password to what they used to start EA from their device, in this case lower case

'a' was our example, and the etp.dat message should be picked up (assuming permissions are set properly please refer to step 1 to verify you see a response in the application log after adding user

to BlackBerry Manager)


A quick search in our knowledge base: http://www.blackberry.com/support
Keyword: Enterprise Activation

Will yield some very useful articles for you to comprise your own checklist for smooth and successful Enterprise Activation

Message Edited by Beholder on 04-22-2009 10:57 AM
New Member
Posts: 1
Registered: ‎11-04-2008
My Device: Not Specified

Re: Cannot activate new user - stuck on 'initializing'

I'm having the same basic issue. I have 7 users and only 5 were able to initialize. One of those took days of retrying. It finally worked when the user was out of town. I've tried auto-generating the password and setting it manually. I even opened up a couple of ports in the firewall that I found in some documentation. Once users are initialized their email, etc works great. Any suggestions?
New Member
Posts: 1
Registered: ‎01-28-2010
My Device: Blackberry Pearl
My Carrier: Vodacom

Re: Cannot activate new user - stuck on 'initializing'

Vector, your point number 7 has resolved my problem. Have been trying to resolve it for the past 3 days!

Thanks for all the help!!