Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

New Contributor
Posts: 3
Registered: ‎09-17-2008
My Device: Not Specified

Enterprise Messenger 2007 upgrade?

I have about 600+ devices that had the 2005 client for LCS installed.  We moved on to OCS 2007 and downloaded the new client.  I can apply the new client to a fresh device either OTA or across the wire just fine and the product works.


What I can't do is upgrade the client on devices that have 2005 on them currently.  For both OTA and wired the install will say that it completes and the list of applications will show it installed but the actual client that's running is the 2005.


If we uninstall 2005 first the 2007 will work.  Here's the rub....that would mean having to touch 600+ devices.  Is there an unobtrusive way to uninstall 2005 OTA or force the BB to upgrade the app to 2007?


I read somewhere (and of course I can't find it now) that this was possibly a known issue and that tweaking SQL may fix the issue.


Any help is incredibly appreciated.


BES - 4.1.6

BB software - Latest available depending on model or carrier

Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: Enterprise Messenger 2007 upgrade?

unfortunately the only way (without using 3rd party assistance) to move from LCS 2005 to OCS 2007 client is to manually remove the 2005 client and then deploy the 2007 client.


This is a bug / flaw with deploying rim signed applications.


I just did this on Monday after confirming testing last week to a pilot group of  people before rolling out to another 100 soon enough.


Its not the answer you want, but its the answer.

If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.

Get busy living, or get busy dying.