Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Developer
Posts: 84
Registered: ‎06-26-2008
My Device: Not Specified

HHCM_DEVICE_NOT_SUPPORTED

I'm getting this error on a new BES 4.1.5 when i try to install applications with a SoftwareConfiguration.

 

Does anybody has this problem? I'm sure that is not a soft problem, nor BB devices. I'm having the same error with a BB 8310 and a 8700.

 

These are BES Policy Service logs:


{0x1844} Error validating package cache: C:\Archivos de programa\Research In Motion\BlackBerry Enterprise Server\PackageCache\FILESHARE_name.domain.local\c$\\ConfiguracionesSoftware\Conf1.1\AppFolder Error: There are no more files.
{0x1844} Failed to InitializeSharedPackageSources for hardwareId 0 and flashSize 0.
{0x1844} Error validating package cache: C:\Archivos de programa\Research In Motion\BlackBerry Enterprise Server\PackageCache\FILESHARE_name.domain.local\c$\\ConfiguracionesSoftware\Soft1.1\MDSRuntime4.2.0 Error: There are no more files.
{0x1844} Failed to InitializeSharedPackageSources for hardwareId 8d000f03 and flashSize 57344.
{0x1844} {user@bes.com, PIN=XXXXXX, UserId=1}RequestHandler:Smiley TongueollForMissingApps: GetHHCodePackages failed with the error: HHCM_DEVICE_NOT_SUPPORTED.

Trusted Contributor
Posts: 185
Registered: ‎07-31-2008
My Device: RIM Z10
My Carrier: PLUS (Poland)

Re: HHCM_DEVICE_NOT_SUPPORTED

Do you delete vendor.xml file from AppLoader? If so then you must reundo this operation to back normal update software from BES.
This not make mistakes, who does nothing.
Włodzimierz Lenin

BES 5.0.4,BES 10.2
Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: HHCM_DEVICE_NOT_SUPPORTED

vendor.xml or do you mean device.xml
------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
Developer
Posts: 84
Registered: ‎06-26-2008
My Device: Not Specified

Re: HHCM_DEVICE_NOT_SUPPORTED

no i did not remove vendor.xml nor devices.xml. I upgraded devices.xml to 1.0.5.5 before the error and still de same.
New Contributor
Posts: 2
Registered: ‎03-23-2009
My Device: Not Specified

Re: HHCM_DEVICE_NOT_SUPPORTED

Hi,

 

i try to install the "B*Nator Remote Control" with software configuration on BES 4.1.6; device.xml file is updated but when i push the application i have this error:

 

[20000] (03/23 15:37:05.225):{0xC40} {xxxxx@yyyy, PIN=251829B2, UserId=32}RequestHandler:Smiley TongueollForMissingApps: GetHHCodePackages failed with the error: HHCM_DEVICE_NOT_SUPPORTED.

 

Any idea?

 

Regards,

Alberto

 

Highlighted
Visitor
Posts: 1
Registered: ‎03-25-2009
My Device: Not Specified

Re: HHCM_DEVICE_NOT_SUPPORTED

Are you having this problem with all 8310 and 8700 devices?  Ive ran into this problem when device agent that sends the device details to the server is bad even though the device and vendor xmls are up to date on the servers.  In your blackberry server manager go to the user in question and look to see if all the device details are listed.   If you dont see all the details especially the model type listed you will get the return error of device not supported.   The only way I know of to fix it is to have the blackberry reload the device OS and then reactivate.  After that it should display the device info and pushing software will begin to work.

 

Ive only ran into this problem about 10-20 times over the past few years (5000+ user BES environment).  It was never much of a concern till we started pushing applications.