Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Contributor
Posts: 3
Registered: ‎09-22-2008
My Device: Not Specified

Mail periodically vanishes from inbox

Hello!

 

Software I have my server:
- Exchange 2007 x64 Standard, 8.1 build 240.6
- BlackBerry Professional Software v4.1.4.3
- MS Forefront Security 10 SP1

Problem:
mail desappear from inboxes once in 1-2 weeks.
Not all mail, but messages older than 1 month (approximately).

Details:
1) This looks like some sort of archiving\cleaning starts periodically, but I didnt set any, and cant find this in any settings.
2) Messages vanish completelly - they arent moven to Deleted folder (checking this by Get-MailboxFolderStatistics).
3) User doesnt synchronize box via POP3.
4) I dont see anything suspicious in Event log even on High level of logging by Exchange. I neither see any clues in Forefront Security logs or Blackberry Server logs.

5) There is no outlook rules setup.

6) Ive made a script to monitor amount of items in Inbox and notify me when this happens to know exact time - and I still doesnt see any clues in logs.


I can restore messages from backup, but this doesnt solve problem (and worse - they get redelivered to handheld as new...).

Is there any way to trace whats going on? I.e. which service deletes mail. Some sort of triggers?


Help please

Regards

Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: Mail periodically vanishes from inbox

Email is being deleted from users mailboxes?  You're not referencing messages on BlackBerry handhelds but rather messages in an actual server mailbox, correct?

 

If so, that has nothing to do with BES.

------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
New Contributor
Posts: 3
Registered: ‎09-22-2008
My Device: Not Specified

Re: Mail periodically vanishes from inbox

[ Edited ]

Thanks for response AndyDufresne!

Yes, its messages in actual Inboxes in Exchange.

Are you sure what BES cant be responsible for this? Even if it is misconfigured or have some problems with mapi\cdo maybe?

If so - this pretty narrows my search.

I just want to be sure in that.

Thanks

Message Edited by Roman on 09-22-2008 12:54 PM
Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: Mail periodically vanishes from inbox

I can't be 100% sure as BES does have mailbox access, but I've never heard of BES doing anything like this.  It isn't how the product is intended to operate, nor in 5+ years have I ever heard / seen of it performing any action like this.
------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
New Contributor
Posts: 5
Registered: ‎07-08-2008
My Device: Not Specified

Re: Mail periodically vanishes from inbox

Sounds like this is something happening on the Exchange side.  The "older than one month" datum is interesting.  Are you doing any sort of Messaging Records Management (MRM) in Exchange 2007?    Is there a Managed Folder Mailbox Policy enabled that could be affecting the Inbox?     

 

The following URL has more detail, as well as information on configuring logging on the Exchange side related to MRM.  http://technet.microsoft.com/en-us/library/bb310793(EXCHG.80).aspx

Highlighted
New Contributor
Posts: 3
Registered: ‎09-22-2008
My Device: Not Specified

Re: Mail periodically vanishes from inbox

The "older than one month" datum is interesting.

Yes, I too found it strange. There is nothing in scheduler, no third party software except BES and Forefront Security (maybe try to uninstall it?..)

 

Messaging Records Management is set to "Never Run" in server params and it is disabled on mailboxes.

 

Ive also tried to search for hidden rules with MFCMapi - cant see any.