Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Contributor
Posts: 13
Registered: ‎04-16-2008
My Device: Not Specified

Service Packs for 4.1.0 bundle60

I'm a newbie and I notice a lot of information about upgrade from one version to another, but not too much on service packs. I would like to upgrade to sp2, is it pretty simple or should I just go to sp4? Does anyone have any documents on upgrading the sp only? Will the online class "Installing Blackberry Enterprise Server Software 4.1 Service Pack 2 for Microsoft Exchange" help me any on this particular issue?
Retired
Posts: 121
Registered: ‎03-31-2008
My Device: Not Specified

Re: Service Packs for 4.1.0 bundle60

Hello efitchett,

Applying service packs and maintainence releases is fairly simple.
There are however best practices to follow before any upgrades.


A quick search in our knowledge base: http://www.blackberry.com/support
Keyword: Best Practices

Will produce documents such as

"Best practices for installing a BlackBerry Enterprise Server service pack " and
"Best practices for installing a BlackBerry Enterprise Server hotfix"

These should be helpful in formulating a checklist of items to go through as best practices before upgrades.





Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: Service Packs for 4.1.0 bundle60

If you have 4.1.0 I would recommend either upgrading to SP4 (and then MR5) or SP5 ...

 

I'm still not sold on SP5, specifically the fact that it was previously scheduled to be released in November 2007 and was just released this past week.  I'm pretty sure we'll be skipping SP5 and will go to SP6; but who knows.

 

SPs and MRs are cumulative so you only need install SP4 to get all that is a part of SP1,2,3 ... or 5 to get 1,2,3,4.

------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
Contributor
Posts: 13
Registered: ‎04-16-2008
My Device: Not Specified

Re: Service Packs for 4.1.0 bundle60

When it first ask you Blackberry or blackberry with MDS I choose MDS, but now it's asking me for th MDS database name. I have the advance tab on the previous version that said Blackberry, did I do the wrong version?

Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: Service Packs for 4.1.0 bundle60

If you don't know your MDS Services database name ... YES, you chose the wrong option.
------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
Contributor
Posts: 13
Registered: ‎04-16-2008
My Device: Not Specified

Re: Service Packs for 4.1.0 bundle60

On the MDS Advance Tab it showed "select a Blackberry Enterprise Server to associate with this MDS Connection serverice: Blackberry is the BlackBerry Enterprise Server Name On the Database Connectivity Tab I have SQL Server Blackberry and Database BESMgmt and the authentication is windows. So did I still choose the worng setup, if so what can I do to fix this? if not then what do I put in the Blackberry MDS Services Database Name and the Blackberry MDS Application registry Database name?
Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: Service Packs for 4.1.0 bundle60

ok, I've lost you ... care to post a screenshot?
------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
Contributor
Posts: 13
Registered: ‎04-16-2008
My Device: Not Specified

Re: Service Packs for 4.1.0 bundle60

I downloaded the Blackberry Enterprise Server v4.1 for Microsoft Exchange and instead of clicking on Blakberry Enterprise Server I did the Blackberry Enterprise Server with MDS. I noticed they have a download for MDS Application but I didn't download that version. So did i download the right version but checked the wrong setup? Someone told me to go to the mdss and look for the password and I did find one under regedit i went to the hkey local machine\software\research in Motion\Blackberry Enterprise server\database and it has the Database Name BESMgmt and Database Server Blackberry. Does this help?

Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: Service Packs for 4.1.0 bundle60

You downloaded the correct version, but you chose the wrong setup.
------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
Contributor
Posts: 13
Registered: ‎04-16-2008
My Device: Not Specified

Re: Service Packs for 4.1.0 bundle60

I had a feeling that's what I did, do you know how I can correct this?