Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Visitor
Posts: 1
Registered: ‎04-14-2008
My Device: Not Specified

Upgrade from 4.1.3 to 4.1.4 failed

Well, my day is just turning out to be grand.

I had scheduled today to upgrade our BES from 4.1.3 to 4.1.4. I read through the upgrade guide, backed up the DB and registry, and was ready to go.

The Groupwise client I had installed was 7.0.2 since our Groupwise admin had set only versions > 7 as allowed to connect. I upgraded to 7.0.3 before the upgrade since I had read in another forum that this version was recommended over 6.5 SP7. Turns out that's not true.

Now I get the following in the GWCO logs:

[54001] (04/14 16:14:28):{0x798} {GWCO} {GWConnector} Starting GWConnector
[34192] (04/14 16:14:28):{0x798} {GWCO} {GWConnector} Database Edition=PERSONAL_MSDE
[34157] (04/14 16:14:28):{0x798} {GWCO} {GWConnector} Novell GroupWiseObject Library: C:\Novell\GroupWise\\gwcma1.dll, Version: 7.0.1
[34493] (04/14 16:14:28):{0x798} {GWCO} {GWConnector} GWConnector Version: 4.1.4.15
[34481] (04/14 16:14:28):{0x798} {GWCO} {GWConnector} GW API Mode=GW_OAPI
[34154] (04/14 16:14:28):{0x798} {GWCO} {GWConnector} Mailstore test start, test level=1
[34116] (04/14 16:14:28):{0x798} {GWCO} {thronsop} Login: Start
[14121] (04/14 16:14:28):{0x798} {GWCO} {} Error checking FID, Error=System.Runtime.InteropServices.COMException (0x80020009): An invalid argument was passed in the function call.
at System.RuntimeType.ForwardCallToInvokeMember(Strin g memberName, BindingFlags flags, Object target, Int32[] aWrapperTypes, MessageData& msgData)
at GroupwareTypeLibrary.DIGWAccount8.get_AccountPrope rty(AccountPropertiesConstants etAcctProp)
at ConnectorLibrary.ICEWrapper.GetFID(String& sCurFID)
[14123] (04/14 16:14:28):{0x798} {GWCO} {}
[14047] (04/14 16:14:28):{0x798} {GWCO} {thronsop} Login Failed, Username=thronsop
[34045] (04/14 16:14:28):{0x798} {GWCO} {thronsop} Logout admin user
[14095] (04/14 16:14:28):{0x798} {GWCO} {GWConnector} Mailstore test failed
[54002] (04/14 16:14:28):{0x798} {GWCO} {GWConnector} Terminating GWConnector

I'm seeing if the Groupwise admin will allow 6.5 SP7 to connect and I'm in the process of reinstalling 6.5 SP7.

However, 7.0.2 worked fine with BES 4.1.3. Anything else I should check?

 

UPDATE:

 

No minimum version set in Groupwise and SSL is no longer required but we get the same error.

The version of GW you are using cannot access this PO.

Now there's this in GWCO logs:

[14123] (04/14 16:51:18):{0x814} {GWCO} {} MultiLogin failed, error=System.Runtime.InteropServices.COMException (0x80004005): Login unsuccessful
at System.RuntimeType.ForwardCallToInvokeMember(Strin g memberName, BindingFlags flags, Object target, Int32[] aWrapperTypes, MessageData& msgData)
at GroupwareTypeLibrary.DIGWSession4.MultiLogin(Strin g vUserID, Object vCommandLine, Object vPassword, Object vWhenToPrompt, Object vReserved)
at ConnectorLibrary.ICEWrapper.AccountLogin(String& sUserID, String& sDomain, String& sPOA, String& sFID3)

Retired
Posts: 79
Registered: ‎04-01-2008
My Device: Not Specified

Re: Upgrade from 4.1.3 to 4.1.4 failed

Have you checked the logging for the Post Office Agent?