Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Highlighted
New Contributor
Posts: 6
Registered: ‎03-02-2009
My Device: Not Specified
Accepted Solution

Upgrade troubles: 3.6.4 to 4.1.4

Hi everyone,

 

I've just been given the task of upgrading my company's BES, but unfortunately I have no experience administering a Blackberry server.  When I run the 4.1.4 setup, I get the following error message after setting up the settings for the Blackberry Configuration Database.

 

"Only one BES is allowed per domain.  Please select another database."

 

There is in fact an already existing DB at the location I specify in these options (BESMgmt).  It seems as if the install program thinks I'm trying to create a new DB for my domain, while in reality I just want to use (or is it overwrite?) the old one from my v3.6.4 software.  Could anyone explain to me what's going wrong here?  Thanks a ton.

Guru III
Posts: 32,116
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Upgrade troubles: 3.6.4 to 4.1.4

4.1 is not a free upgrade, did you buy the upgrade kit for 999.00 USD?

 

You did not mention mail server but pricing is same.

http://na.blackberry.com/eng/services/server/exchange/#tab_ddetail_subtab_pricing

http://na.blackberry.com/eng/services/server/domino/#tab_ddetail_subtab_pricing

http://na.blackberry.com/eng/services/server/groupwise/#tab_ddetail_subtab_pricing

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


New Contributor
Posts: 6
Registered: ‎03-02-2009
My Device: Not Specified

Re: Upgrade troubles: 3.6.4 to 4.1.4

Yes, my company purchased 4.1 a few months ago, but it was $849.00. It's for Exchange.

 

Also I'm not convinced this is an upgrade kit. The product description is: "BlackBerry Professional Software 4.1 for Microsoft Exchange - 10 User".  Could the problem be that I need to install this package from scratch?

 

The person who purchased the software will be away for a few days, so I can't verify the purchase details with him right now.

Guru III
Posts: 32,116
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Upgrade troubles: 3.6.4 to 4.1.4

Depending on what few months mean, might want to call RIM and see if you can exchange it for the upgrader kit.

 

How many users on 3.6?

 

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


Forums Veteran I
Posts: 2,036
Registered: ‎12-04-2008
My Device: 8900

Re: Upgrade troubles: 3.6.4 to 4.1.4

I agree, I'd call RIM and be honest, they have been good to me in the past.
******************************************************************


If someone helped you give them kudos. Research all info!
New Contributor
Posts: 6
Registered: ‎03-02-2009
My Device: Not Specified

Re: Upgrade troubles: 3.6.4 to 4.1.4

So apparently, back in January we talked to an RIM representative about getting the necessary software to allow for more than 15 handhelds for our server.  He recommended we purchase the following item:

 

BlackBerry Professional Software 4.1 for Microsoft Exchange for $849

 

However, you seem to be recommending we buy this package:

 

BlackBerry Enterprise Server v4.1, Service Pack 6 Version Update for $999

 

----

 

The site doesn't offer much help as to what exactly these packages include, so here's my question: I'm guessing that the first package is a from-scratch installation, and the second is simply a software upgrade and it doesn't add any capability for more handhelds.  However, if that's the case, why would the stand-alone 4.1 version of the software cost more than an upgrade?  This is even more surprising since from what I've gathered, the first package enables more users to connect to the server.  Given my surprise, I'm guessing some of my assumptions are incorrect.
Guru III
Posts: 32,116
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Upgrade troubles: 3.6.4 to 4.1.4

[ Edited ]

I bet you only had 15 licenses on the 3.6 server that prevented you adding more users.

You have a full BES already so 999 upgrade makes sense since full BES would cost 3000.00 for 1 users.

Then you can add user cals for about 429.00 so 1429.00 total

 

 

With BES Pro you would have to spend almost the same amount to start fresh and lose the Full BES you paid for.

849 plus 5 more users CALs 499.99 and not get all the functions of FULL BES like HTML email and no lock on amount of users.

Ok so maybe you save 80.00 or so. Not worth it in the long run when you have to shell out 2800 to upgrade to full BES in the future for more than 30 users. And you already had it to begin with.

 

CALL RIM

 

 

Message Edited by knottyrope on 03-02-2009 12:08 PM
Message Edited by knottyrope on 03-02-2009 12:10 PM

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


New Contributor
Posts: 6
Registered: ‎03-02-2009
My Device: Not Specified

Re: Upgrade troubles: 3.6.4 to 4.1.4

Turns out I had to fiddle with some configuration files to change the setup into an upgrade vs. a stand-alone install.  That, and manually migrate my old 3.6 database to 4.1.

 

Thanks for the advice everyone.

Visitor
Posts: 1
Registered: ‎03-18-2009
My Device: Not Specified

Re: Upgrade troubles: 3.6.4 to 4.1.4

Could you please post what you had to do so others finding this thread can get help as well?

 

thanks

New Contributor
Posts: 6
Registered: ‎03-02-2009
My Device: Not Specified

Re: Upgrade troubles: 3.6.4 to 4.1.4

[ Edited ]

If I recall correctly, everything I had to do was explained in this article:

 

http://www.blackberry.com/btsc/KB10354

 

It took the RIM tech support guys 10 minutes to find it... but it did the trick.

Message Edited by CJLGreg on 03-19-2009 08:46 AM