Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Contributor
Posts: 24
Registered: ‎07-29-2008
My Device: Not Specified

"Decryption Failed, Please regenerate the Key" - OTA Activation issue

Hi,

 

I've recently wiped out one of the BB handhelds from BES manager (deleted & then purged the user from BB MGR console) & then asked the user to wipe out his device from HH, options -> Security Options -> General Settings.

Later, I re-added the same user in BES MGR & generated & sent the activation p/w through mail. When user tried to (re)activate the same device immediately after a wipe out (OTA), it said, "Decryption Failed, Please regenerate the Key".

What could be the reason for this error ? I read somewhere on blogs, saying that decryption key associated with the old BES server still remains for "7" days on a HH, after its wiped out completely.

If that is the case, how to manually delete the decryption key then?

Developer
Posts: 333
Registered: ‎04-16-2008
My Device: 8900

Re: "Decryption Failed, Please regenerate the Key" - OTA Activation issue

You could try this and see if it works:

 

Options--> Security Options -> General Settings

 

Scroll down to the bottom until you Services.

 

Higlight the service book that is associated to your BES and click.

 

Select regenrate encryption key from drop down menu.

 

Let me know if it works...

Highlighted
Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: "Decryption Failed, Please regenerate the Key" - OTA Activation issue

... and that is why I don't use the purge user option ... eh, I've got no other suggestion unfortunately, except for don't use purge user; if everything is working correctly the user will be removed within a few minutes of the deletion.
------------------------------
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.


Get busy living, or get busy dying.

http://blog.port3101.org/hdawg/
Contributor
Posts: 24
Registered: ‎07-29-2008
My Device: Not Specified

Re: "Decryption Failed, Please regenerate the Key" - OTA Activation issue

I later realized that we were testing the trial version of BES in our test exchange 2007 environment, which did not have MX records registered & hence the activation request mails with ETP.dat attachment could not reach the ID specified at the time of activation !!

 

I supplied a live email ID & did receive an email with said attachment on that ID later !!