Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Contributor
Posts: 3
Registered: ‎07-01-2009
My Device: Not Specified
Accepted Solution

BB Pro Software Activation

[ Edited ]

Hello,

 

SHORT VERSION:

I have 4 users wanting to use BBPS.  My BESAdmin account has identical permissions over all 4 users' mailboxes.  The first user activated with no problem, the other 3 get stuck at "Activation" and the .etp file sits in their mailbox until they delete it after a day or two.

 

 

FULL VERSION:

I am having a problem with 3 of my 4 users' phones getting stuck on "Enterprise Activation, Activating".  Up until about a week ago all 4 users just got their email forwarded on to them from our webserver mail (3 of the 4 used the Blackberry Desktop redirection).  Then, one of them wanted to try out Blackberry Professional Software so that their calender/contacts/read/deleted mail would sync up with their outlook. 

 

So I downloaded the trial deal with 1 free CAL.  I looked up how to install it, made my BESAdmin account on the server, installed the software and was able to activate my user with almost no problems (I accidently installed from my local admin account so I had to uninstall and reinstall from the BESadmin account) .  Everyone liked it so we went ahead and bought the 5 CAL package.

 

In the Blackberry Manager, I went to License Management and added the new license.  I also went to the "Edit server properties" link on the "Home" tab of BBMngr and switched the SRP ID and Key to the ones provided with the 5 CAL package.  I added my 3 new users with no problem.  

 

I manually set the activation passwords (later I also tried the "generate password and email" option - it didn't work any better) for them and tried to activate them from their devices.  All 3 of them got stuck at Activating.  The .etp emails are being sent to their mailboxes, but they just stay there and never disappear.  It sounds like this is because BESAdmin lacks permission to "read" and "send as" these users.  However, its been driving me up a wall because there was no problem with my first user and all 4 of these guys are nearly identical objects in Active Directory Users and Computers.

 

After uninstalling, assigning full mailbox control to BESAdmin over all 4 users, and reinstalling, I still have this problem.  My first user is up and running perfectly, my other 3 users cannot get past the Enterprise Activation:Activating line on their devices.

 

Any Ideas?

 

 

 

One difference I could see between the user whose phone is activated and the other 3 is that his was the only phone to have "Enterprise Activation"  in the location where all the activation guides said it would be (Options->Adv. Options->Enterprise Activation).  To get to it from the other 3 phones I have to go to Setup Wizard->Email Setup->I want to use a work email with BBES->Yes, my system admin has given me an activation password-> only then does it take you to Enterprise Activation.  I can't see this being a major problem but its the only difference I can find.

 

 

Background:

I have Blackberry Professional Software v.4.1.4.17 installed on a 2003 Small Business Server.  We are using Microsoft Exchange 2003.

The user phone types are 2 Blackberry Pearls, 2 Blackberry Curves (I think they are curves, I can check if this is relevant)

 

 

Thanks in advance and sorry about the length of my post, didn't want to leave anything out in case it was important.

-Brian

 

 

 

 

 

EDIT:  I've tried something different, and given read/send as permission to BESAdmin for all users on my domain.  I still can't activate them.  Do I need to do a fresh install after changing these permissions?

Message Edited by Brian1821 on 07-01-2009 03:30 PM
Guru III
Posts: 32,126
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: BB Pro Software Activation

If etp.dat does not get picked up by BPS then it is a permissions related issue.

 

read more an permissions here

http://www.blackberry.com/btsc/KB02276

 

Is the user hidden in the GAL?

 

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


New Contributor
Posts: 3
Registered: ‎07-01-2009
My Device: Not Specified

Re: BB Pro Software Activation

Nope, It is not hidden in the GAL.  I thought it might be a permissions issue, its just confusing me since one of my users was able to activate and he is virtually identical in all settings to the other 3.  Thanks for the link, I'll see if I can get any new information out of the article.
Retired
Posts: 616
Registered: ‎03-25-2009
My Device: BlackBerry Curve 9360
My Carrier: Bell

Re: BB Pro Software Activation

If the users used to use Desktop Redirector, there may be a conflict. Desktop Redirector uses ETP messages too. Have you uninstalled the Desktop Manager software from their systems? If not, you may want to make sure that's done first. If they still need it, they can re-install it and integrate it with the server after their device is activated.

 

Also, check the ETP to make sure it isn't being touched by anything else. SPAM and anti-virus software love to append tags or text to the messages. The BES/BPS will not pick up the message if it has been altered.

 

There is a useful tool called IEMSTest. You can find it in the directory where BB Pro is installed. Running it as the besadmin account will allow you to confirm that the necessary permissions are in place to read/write to the mailbox. 

 

Lastly, when all else has failed, I like to try the activation with Outlook closed.

______________________________________________
The only stupid question is the one you don't ask before you reboot the BES.
New Contributor
Posts: 3
Registered: ‎07-08-2009
My Device: Not Specified

Re: BB Pro Software Activation

Hi

 

I am having the exact same problem under pretty much the same circumstances.

Did you have any luck in solving this issue.

 

The iemstest utility show the test completed succesfully for the user that canot activate.

I even see the message traffic for the user in the exchange smtp logs for th etp message and this seems ok too.

 

Thanks in advance

Steve

New Contributor
Posts: 3
Registered: ‎07-01-2009
My Device: Not Specified

Re: BB Pro Software Activation

[ Edited ]

Thanks for the information Cereal.  I tried uninstalling the redirector and closing outlook, no luck there though.  Afterwards, I deleted all my users, wiped the device that was working, uninstalled Blackberry Professional Software, and even deleted my BESadmin account.  I started all over from the beginning and ran into the same problem.  The same guy's phone is the only one of the four that will activate.

 

Steve,

I think I'm going to give in and buy a one time incedent support deal from Research in Motion.  I'll let you know if I figure anything out.

 

 

 

EDIT: Steve, just curiously, did you start with the 1 free CAL and that worked so you bought a few more and just added the license in the "license management" on Blackberry Manager?  Thats what I did and I'm wondering if thats why I only have my first user activating (even though it shows I have spots for 6 users)

Message Edited by Brian1821 on 07-08-2009 10:21 AM
New Contributor
Posts: 3
Registered: ‎07-08-2009
My Device: Not Specified

Re: BB Pro Software Activation

Brian

 

I will  continue to work the problem and if I get any where I'll let you know. When you reinstalled did you just install the 5 CALS or did you install the free one and the other 5 CALS.

New Contributor
Posts: 3
Registered: ‎07-08-2009
My Device: Not Specified

Re: BB Pro Software Activation

Brian

 

I did the same as you. i was going to try the reinstall with jus the 5 CALS.

 

Stev

Guru III
Posts: 32,126
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: BB Pro Software Activation

The CALs have nothing to do with your problem.

 

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


Retired
Posts: 616
Registered: ‎03-25-2009
My Device: BlackBerry Curve 9360
My Carrier: Bell

Re: BB Pro Software Activation

[ Edited ]

Brian: 

If it's one device that won't activate, it could be something on the device end.

 

Licensing shouldn't be the difference. Here's how I like to check out activations

 

Step 1: Check provisioning

- Make sure the device is enabled for BlackBerry Enterprise Service

- This can be done by checking with the carrier or by contacting your friendly neighbourhood BlackBerry support rep at RIM

- If you're a BTSS/T-Support subscriber, you're given access to a dashboard that will allow you to check on your own.

 

Step 2: Checking for the ETP message

- Make sure the user is not on the server

- On the device, try an activation as though you did add the user to the server

- Of course, the activation won't work because the user isn't on the server, but the ETP message should land in the inbox of the mailbox

- If the ETP does end up in the inbox, make sure it hasn't been modified by SPAM or anti-virus software. Also, make sure the attachment is there

- Assuming the message is there and unmodified, delete it and move to step three

 

Step 3: Make sure the user starts on the messaging agent

- Add the user to the BlackBerry server

- Pop open the Windows Event Viewer

- If all goes well, you should get an Information Event from the BlackBerry Messaging Agent indicating the user was added to the BES

- If something is wrong, you'll get a warning like "1 user failed to initialize" and there will likely be another warning indicating why the user failed to start

- If you don't get an information event OR a warning, check to make sure the BlackBerry services (specifically the Controller) are running.

 

That's usually how I will start troubleshooting activation issues.

 

 

Message Edited by CerealBypass on 10-01-2009 11:51 PM
______________________________________________
The only stupid question is the one you don't ask before you reboot the BES.