Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

New Contributor
Posts: 4
Registered: ‎09-02-2008
My Device: Not Specified

Exchange / BPS stopped working

We are running BlackBerry Professional on a Win Server 2003 box alongside a SBS 2003 box. 

On the weekend my business experienced a power out which meant that our SBS and BES servers restarted. I should also point out that daylight savings here in Melbourne kicked in over the weekend - just to cloud the issue.

Since that time, synchronization between Exchange & BES hasn't worked. 

Prior to this, everything has been running fine for over 12 months.

I have restarted the BES server twice since the initial restart, just to ensure that BES was starting after Exchange and AD was up and going. All BES services are running fine.

If I send a pin message from BlackBerry manager then all devices get it but not emails.

I tried to activate my device again (all 16 users have BlackBerry Pearls) but this isn't working either. I get an ETP email in my inbox when I try to activate and then another one 5-10 minutes later when the activation finally fails).

I notice in the Users tab of BlackBerry Manager that the Last Contact Time for all users is before the server restarts occurred.

No service packs or other updates were applied on the servers when they restarted.

What should I be looking at to solve this problem?
Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: Exchange / BPS stopped working

Start with the BES logs ... is there anything in the ALRT or CTRL log that looks like an error?


 If you'd like, zip up a set of the days logs and email it to BBAndyDufresne@gmail.com. Please also make sure to include a link to this thread so I know what the message is referencing / where to respond.

I'll post back any relevant content removing anything personally identifiable / confidential.

If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.

Get busy living, or get busy dying.

New Contributor
Posts: 4
Registered: ‎09-02-2008
My Device: Not Specified

Re: Exchange / BPS stopped working

Thanks for the reply.


After going through all permissions etc. I gave in and reinstalled BPS and it solved the problem. I guess that something must have become corrupted.