Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Posts: 10
Registered: ‎06-10-2009
My Device: Not Specified
Accepted Solution

MAPI Versions

[ Edited ]


I have an Windows 2003 SBS with Exchange 2003 SP2 and I am installing BES on it's own seperate server.


My understanding on MAPI and CDO versions are that you need to have the same version as is running on your Exchange or a higher version. For Example Exchange 2000 SP3 needs ESM 2000 SP3 or ESM 2003 or higher.


Question In my case I don't want to install ESM 2003 on my BES hardware and was wondering if anyone knows if I can install the MAPI and CDO 1.2.1 pack on the BES.


Thanks James

Message Edited by thefifthrace on 06-22-2009 07:23 AM
Forums Veteran II
Posts: 2,744
Registered: ‎04-01-2008
My Device: Bold

Re: MAPI Versions

It'll work, but it isn't the recommended implementation. That said, I've done it and have had no problems ... but I'm generally a fan of matching MAPI/CDO dlls whenever possible.
If you've found a solution through a post; please mark it as a solution.
If someone's was particularly helpful, give them kudo's!.

Get busy living, or get busy dying.

Posts: 10
Registered: ‎06-10-2009
My Device: Not Specified

Re: MAPI Versions

It might have to do in this case as I don't have access to a Exchange CD to install the ESM


Thanks for the help