Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎06-17-2011
My Device: BlackBerry Torch 9800
My Carrier: KPN

Not all e-mail is received on handheld using BESX

I have recently installed Microsoft Exchange Server 2010 on a new server running Microsoft Windows Server 2008 R2 Standard, together with a fully updated copy of BlackBerry Enterprise Server Express 5.0.2. I created an account for myself, set up my BlackBerry Torch 9800 using Enterprise Activation and during my testing period everything went fine. I created accounts for all other users and I took the server into production. Of all other users, I only set up around five more users to use their BlackBerry handhelds with the new server. On a side note, the other users do not use the e-mail functionality on their BlackBerry heldhelds at current.

 

The new server has been in production for around two weeks now and everything is working fine, except for one thing. For the past week I have noticed that I do not receive all of my new e-mails on my BlackBerry handheld. E-mails sent to me from BlackBerry, Gmail, et cetera arrive without any issues as it seems, but when collegues send me e-mails, not all of them arrive. One collegue who is also using the new server with his BlackBerry handheld states that he has not received any new e-mails on his BlackBerry handheld for a week now. Another collegue however states that he does not experience any issues and receives all e-mails, no matter if it is from collegues or from outside of our company. I still need to double check for myself if I only sometimes receive e-mails from collegues or if I never receive e-mails from collegues at the moment. Calander items and contacts are synchronised without any issues.

 

To resolve this issue I have verified if Send As was set up correctly, which it was. I have updated our BlackBerry Enterprise Server Express from version 5.0.2 to version 5.0.3, but the issue remains. I ran iemstest.exe as BESAdmin and it only fails on the last step, which is by heart Configuring User. From what I understand this has to do with EWA, so it could not be the cause of this issue and this "error" can be safely ignored. I have also set up my e-mail account again on my BlackBerry handheld using Enterprise Activation, but it did not solve my issue. I am absolutely clueless at current what could be causing this issue. Has anyone experienced something similar before or does anyone know what may be the cause of this issue?

 

What I did notice, and I have no idea if this is normal or not, is when I open my E-mailaccounts on my BlackBerry handheld that I can only see my personal Gmail account mentioned. Behind the word E-mailaccounts I do see a number 2 however. When I open Enterprise Activation, I can see my Desktop account being mentioned at the top as well. Is it normal that you do not see the Desktop mentioned in E-mailaccounts I wonder? I have not compared this yet to the user which experiences (almost) the same issue or with the user which does not experience any issues, to see if it looks the same on their BlackBerry handhelds.

 

I hope that someone can shed some light on this issue. I thank everyone in advance for any help they may be able to offer on this matter.



- Microsoft Windows Server 2008 R2 Standard
- Microsoft Exchange Server 2010 SP1
- BlackBerry Enterprise Server Express 5.0.3 with KB22953
New Contributor
Posts: 2
Registered: ‎06-17-2011
My Device: BlackBerry Torch 9800
My Carrier: KPN

Re: Not all e-mail is received on handheld using BESX

Kudos to me! Well, partly anyway... Smiley Wink

 

I managed to find out what caused my personal e-mail problem. I have several rules configured in Outlook which are stored on Exchange, moving new e-mails around to my liking. These new e-mails do not show up in the inbox of my BlackBerry handheld. When I disabled the corresponding rule, an affected new e-mail would arrive on my BlackBerry handheld as it should. I have re-enabled the corresponding rule in Outlook, however this time placing a check mark next to "On this system only". Now my e-mail rules are no longer applied on Exchange, but only on Outlook itself, solving my issue.

 

There however is still one user who does not receive any e-mails at all on his BlackBerry handheld, so I will still have to look into that issue, but it is an isolated case as it seems, so it most likely simply is a case of "Replace user and try again". Smiley Wink



- Microsoft Windows Server 2008 R2 Standard
- Microsoft Exchange Server 2010 SP1
- BlackBerry Enterprise Server Express 5.0.3 with KB22953
Guru III
Posts: 32,116
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Not all e-mail is received on handheld using BESX

Sounds like excahnge is processing the emails before BES can detect them.

 

if that is the case you need to enable folder redirection on the folders you wish to see.

 

 

 

KB11434 - No messages are displayed in subfolders following enterprise activation

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V