Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
Posts: 8
Registered: ‎09-04-2009
My Device: Not Specified

Application Deployment error (Permissions)

I am getting an error when attempting to publish any application as follows

 

"The BlackBerry Administration Service was unable to store the application due to the directory permissions on the application network share. Please change these permissions. "

 

In the logs, I find the following.

"com.rim.bes.bas.softwareconfigurationmanager.CouldNotWriteApplicationsToShareRollbackException: exportAppLoaderFiles network share directory does not exist or is not writable."

 

Any advice - I have tried making sure BESAdmin has write permissions for the Package Cache directory.  Is there a way to specify the directory that BAS stores the files on?

New Member
Posts: 1
Registered: ‎09-25-2009
My Device: Not Specified

Re: Application Deployment error (Permissions)

*bump*

I get the same error.  I also cannot even find a "PackageCache" directory anywhere.  Where does the BES server store these applications, i.e.: which directory is it not able to access?

New Member
Posts: 1
Registered: ‎09-24-2009
My Device: Blackberry Bold 9000

Re: Application Deployment error (Permissions)

Good afternoon,

 

I wanted to enquire if you ever found a resolution to this problem as I'm experiencing it now?

Highlighted
New Contributor
Posts: 7
Registered: ‎08-25-2013
My Device: Q10
My Carrier: China Mobile

Re: Application Deployment error (Permissions)

Hello,I got the same error in bes10,have u got the exact reason?