Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Highlighted
Regular Contributor
Posts: 65
Registered: ‎10-11-2010
My Device: Bold 9700
My Carrier: AT&T
Accepted Solution

BES 10 install fails to connect to SQL DB

I have the "guide" aka walk through on install. I did not run the cfg files. I installed SQL express 2008 w/ tools (studio management). This also failed when BES 10 tried to install its own sql express version.

 

The BES service account is local admin, also a sysadmin in sql. Using static port 1433 w/ windows authentication.

 

Error during BDS sql install is, an attempt to connect the database was unsuccessful. for more info check logs. Well the logs don't say much for this specific error unless I'm looking in the completely wrong spot. 

 

Regular Contributor
Posts: 65
Registered: ‎10-11-2010
My Device: Bold 9700
My Carrier: AT&T

Re: BES 10 install fails to connect to SQL DB

[ Edited ]

tried to use SA to create BDSMgmt and still failes. I shuold also state this is a local SQL 2008 express install as our big SQL environment is still on 2005.

Trusted Contributor
Posts: 146
Registered: ‎08-18-2010
My Device: Z10
My Carrier: Vodafone.de

Re: BES 10 install fails to connect to SQL DB

Hi northvibe,

 

I had a similar issue and solved it by enabling port 1433 in the SQL Server Settings.

In our environment we are using SQL Express on the BES 10 Server

 

All Programs->Microsoft SQL Server 2008 R2->Configuration Tools->SQL Server Configuration Manager

 

SQL Server Network Configuration

 

Set Named Pipes and TCP/IP to enabled and in the TCP/IP settings in the Tab IP Addresses add 1433 in the TCP Port Field.

 

Restart the SQL service afterwards. And try your installation again.

 

Hope this helps

 

Regards,

hape

 

 

Regular Contributor
Posts: 65
Registered: ‎10-11-2010
My Device: Bold 9700
My Carrier: AT&T

Re: BES 10 install fails to connect to SQL DB

bb10 v1.PNG

 

bb10 v2.PNG

 

Which "port" spot did you put the 1433? for all or the one with the IP? Thank you!

Regular Contributor
Posts: 65
Registered: ‎10-11-2010
My Device: Bold 9700
My Carrier: AT&T

Re: BES 10 install fails to connect to SQL DB

I did as Hape said and put 1433 at the bottom of the IPALL and it worked...that was such a frustruating issue. WHY!?!?!?!