Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
Posts: 4
Registered: ‎09-08-2009
My Device: Not Specified

BES 5.0 - Prepopulation does not work

Hi guys,

 

We are running BES 5.0 for MS Exchange with MR2.

 

Whenever I activate new user, no old emails are being sent to device, just the new ones. New emails are arriving instantly, either through desktop manager, or through wireless network.

 

I tried to wipe the device and delete it from BES (I also opt to remove BlackBerry info from user's mailbox) and then I re-activated the device, but still the same thing happens after the activation.

 

I tried from two different Blackberry devices, for 3 different users, but behavior is always the same - only new emails arrive to device.

 

I tried to change message prepopulation settings to sync last 14 days (or 250 messages), but no luck.

 

I even tried to use the registry hack 'ForceMsgPrepopOnActivation', and rebooted the server after that, but to no avail.

 

I tried to restart BlackBerry synchronization service, no joy. All BlackBerry services seem to be running, and there is nothing really suspicious in Event Viewer, except one warning message that DBNS component is not installed.

 

In the BES5_SYNC log file, the only suspicious entries are the following:

 

[30000] (10/09 13:42:55.931):{0x1BA0} [ENV] BlackBerry User Administration Service: NOT FOUND
[30000] (10/09 13:42:55.931):{0x1BA0} [ENV] BlackBerry Database Consistency Service: NOT FOUND

 

However, both Blackberry Administration Services (Application Server an Native Code Container) seem to be running OK. There is no service named Blackberry User Administration Service - should it be there at all?

 

When I installed BES, I did not install MDS Data Integration service, could this be related?

 

Thanks for all the help.

Contributor
Posts: 16
Registered: ‎10-14-2009
My Device: Not Specified

Re: BES 5.0 - Prepopulation does not work

Gaston, Just to be sure, these are all new activiations, as in the users have never had BES before? If not, there's a registry key to force the prepopulation data. Just to be clear, this is to force prepopulation of data to blackberries that are being "reactivated" using the Enterprise Activation. [HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\BlackBerry Enterprise Server\Agents] “ForceMsgPrepopOnActivation”=dword:00000001 “ForceMsgPrepopDays”=dword:0000000e “ForceMsgPrepopMessages”=dword:000002ee The high limits for this hack are 14 days or 750 messages. (in hex in the above entries) Just the entry type to decimal and enter the size limit that you want. Please use this in a test environment prior to changing your production. Thanks!
New Contributor
Posts: 4
Registered: ‎09-08-2009
My Device: Not Specified

Re: BES 5.0 - Prepopulation does not work

Thanks rueburbon.

 

I already tried these registry hacks but it didn't help.

 

Message prepopulation does not work neither for new activations, nor for re-activations.

 

On the other hand, new messages are being forwarded to devices instantly.

 

I have no clue what to try next...

New Contributor
Posts: 3
Registered: ‎12-16-2009
My Device: Not Specified

Re: BES 5.0 - Prepopulation does not work

Did you ever find a resolution to the pre-population issue? We are experiencing the exact same thing, and are in need of a solution.

 

Thank you,

New Member
Posts: 1
Registered: ‎12-30-2009
My Device: 9530
My Carrier: Verizon

Re: BES 5.0 - Prepopulation does not work

[ Edited ]

I recently spent 4 hours on the phone with Blackberry support trying to find any answer to why prepopulation is not working properly.  I found your and my issue is a known issue.  The issue number I was given is 511315.  There is no known fix at this time.

New Member
Posts: 1
Registered: ‎11-17-2011
My Device: 9800
My Carrier: Chunghwa Telecom

Re: BES 5.0 - Prepopulation does not work

Does anyone find any solutions for this? I've tried changing setting on BES also registry with no luck.

 

  1. In the BlackBerry Administration Service, on the Servers and components menu, expandBlackBerry Solution topology > BlackBerry Domain > Component view > Email.
  2. Select the desired instance to be changed.
  3. Click Edit instance.

 

On the computer hosting the BlackBerry Enterprise Server, open the Registry Editor.

  1. For 32-bit versions of Windows Server®, go toHKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\BlackBerry Enterprise Server
  2. For 64-bit versions of Windows Server, go toHKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Research In Motion\BlackBerry Enterprise Server
  3. Right-click the Agents registry key, then click New > DWORD Value.
  4. Typgi     e ForceMsgPrepopDays as the new DWORD Value name, then press ENTER.
  5. Double-click ForceMsgPrepopDays.
Highlighted
Guru III
Posts: 32,116
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: BES 5.0 - Prepopulation does not work

what version BES are we talking about?

 

have you tried this?

 

KB11632 - How to increase the number of email messages sent to a BlackBerry smartphone during the en...



If using the same PIN upon activation look at this KB

KB04713 - Enable message prepopulation for all users on a BlackBerry Enterprise Server



For subfolders you have to enable them first.

KB11434 - No messages are displayed in subfolders following enterprise activation

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V