Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Developer
Posts: 61
Registered: ‎04-04-2008
My Device: BlackBerry
My Carrier: Vodafone

BlackBerry Device Service Failed with return code of 7

We just started with out BES 10 upgrade the last weekend, but it failed with the error:

 

---------------------------
BlackBerry Device Service Installation
---------------------------
The setup application was unable to obtain LDAP information about the BlackBerry Service administrator account. Please refer to the BlackBerry documentation and to the installation log file for more information.
---------------------------
OK   
---------------------------

the log shows:

-------------------

<#01>[10000] (04/17 20:49:09.916):{0x898} CBASUtilitiesCon::GetADUserInfo - Failed with return code of 7, parsed from result ... AuthIID=[] ObjGUID=[] DispN=[] AuthTID=[]
<#01>[10000] (04/17 20:49:09.916):{0x898} CBASAdministrativeAccountCon::Validate: GetADUserInfo failed, code 7
<#03>[30000] (04/17 20:49:09.916):{0x898} CBASAdministrativeAccountCon::Validate: result code from validating was [13] - [Mode=1, UseCurrAcct=1, WinUser[], WinDom[], BASUser[admin], BASPwd[<NIL>], BASPwdCon[<NIL>], AE[0]CES[1], IVA[1/0/0] LD[1]WD[0] RO[0]]
<#01>[10000] (04/17 20:49:09.916):{0x898} CDataContainer:Smiley Very HappyoValidate: CBASAdministrativeAccountCon failed to validate. Result: 13.
<#01>[10000] (04/17 20:49:09.916):{0x818} [CBASAdministrativeAccountCon:Smiley Very HappyoValidate]: Validation failed
<#03>[30000] (04/17 20:49:09.916):{0x818} Could not load a caption - defaulting to banner title.
<#04>[40000] (04/17 20:49:23.572):{0x818} AdvancedAdminDlg executes EnableControls.

------------------

 

Does anybody knows why?!?! Must we install MAPI on the same server where the BlackBerry Device Service is installed? If yes where the hell is that written?!?!

Bastian W.
Retired
Posts: 2,283
Registered: ‎09-09-2010
My Device: BlackBerry Z10 Smartphone

Re: BlackBerry Device Service Failed with return code of 7

Hey BastianW,

 

Please review the following article for information on how to resolve this issue:

 

"Installer was unable to obtain LDAP information about the BlackBerry service account" during installation of the BlackBerry Enterprise Server or BlackBerry Device Service

http://www.blackberry.com/btsc/KB21663

 

Let us know if you have any questions.

Thanks.

-HB

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!