Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
Posts: 4
Registered: ‎07-01-2013
My Device: Z10
My Carrier: MTS

Bug of feature: activation with sim card

Dear all,

may be you will be able to help me ;-)

 

We have BES 10. User is set up for Balance.

 

If we are activating device via public Wi-Fi, without sim-card in device (Z10, Q10 - doesn't matter) - activation goes OK and everything works more less fine.

 

In case we just inserting any sim-card, in same device, connected to same public WiFi network, even with mobile network connection turned off - device immediatelly writes that "Activation Error. The server couldn't be contacted. ...".

 

Device firmwares are different - 10.1.0.4181 - the newest we've tested.

How to fix that? It's not nice, that BB cannot be used with sim-card - i need it not only in wi-fi places ;-)

 

Thanks for any comments on that ;-)

 

Contributor
Posts: 16
Registered: ‎07-17-2013
My Device: BlackBerry Z10 STL100-3

Re: Bug of feature: activation with sim card

This is likely due to not having the appropriate data plan provisioned with your provider.  If you're attempting to activate over-the-air, you need the proper plans...  Hope that helps!

Mark
Systems Analyst
---
BlackBerry Enterprise Server 5.0.4 (Bundle 100)
BlackBerry Enterprise Service 10.1.1
Microsoft Exchange 2013

New Contributor
Posts: 4
Registered: ‎07-01-2013
My Device: Z10
My Carrier: MTS

Re: Bug of feature: activation with sim card

May be, but this sim card works perfect with BES5 on other phones, and, again, even with mobile connectivity totally switched off it doesn't work via WiFi as well.

And again, i'm not looking for regulated activation - we are activating Balance user...

 

To be honest, for me it's very strange ;-)

Highlighted
Contributor
Posts: 16
Registered: ‎07-17-2013
My Device: BlackBerry Z10 STL100-3

Re: Bug of feature: activation with sim card

I had to have a different data package for my Z10 compared to my Bold9900 -- I believe this is likely the issue and you should contact your wireless provider and verify the proper data plan is provisioned for use with the Z10 for non-WiFi activations.

 

Also, it's hard to offer a solid solution as the SIM requirements vary depending on carrier.  Though my Bold9900 SIM was not compatible with the Z10 and I had to obtain a newer Micro-SIM to work with it.  If you're putting an incompatible SIM into the phone you may likely run into several issues including damage to the delicate circuitry.

 

I would still visit your respective carrier and verify your SIM is compatible with the phone and/or the data plan is provisioned properly to work with the phone if you wish to attempt non-WiFi activations.

 

Further, introducing a carrier SIM to any phone also introduces carrier specific logic to that phone.  It may be likely that this logic is interferring with the activation even though you have the mobile connectivity in an "off" state.  Such as with my carrier whom has WiFI specific logic allowing free WiFi on their branded hotspots.

Mark
Systems Analyst
---
BlackBerry Enterprise Server 5.0.4 (Bundle 100)
BlackBerry Enterprise Service 10.1.1
Microsoft Exchange 2013

New Contributor
Posts: 4
Registered: ‎07-01-2013
My Device: Z10
My Carrier: MTS

Re: Bug of feature: activation with sim card

Ok, thanks, i'll try. Problem it that till now BES10 / ZQ10 are not officially supported by provider... So, i'll keep pushing them ;-)
Thanks again