Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
Posts: 4
Registered: ‎06-01-2009
My Device: Not Specified

Cannot login using Active Directory. Wrong LDAP servername in LOG.

Can someone please help me? For the life of me i cannot figure this one out.

 

I can login locally using the local bas and the admin account.

 

I get a bad username bad password user not found error message when logging using Active Directory authentication.

 

here is the snippet from the log file:

 

(06/02 14:45:41:756):{http-BES.MyDomain.INC%2F10.0.0.104-443-1} [com.rim.bes.basplugin.activedirectory.LdapSearch] [INFO] [ADAU-1001] {u=SystemUser, t=5561} LOGIN ERROR:  getActiveDirectoryRootDseInformation could not get rootDSE attributes for URL ldap://MyDomain.inc:389 error=javax.naming.CommunicationException: Rideau.inc:389 [Root exception is java.net.ConnectException: connect: Address is invalid on local machine, or port is not valid on remote machine]

 

the ldap server listed is missing the first part of the host name: should be ldap://ns1.Mydomain.INC:389 and not ldap://mydomain.inc:389

 

Is there tech support available for those running the trial? Won't make the purchase if cannot resolve this retarded issue.

 

thanks everyone.

New Contributor
Posts: 4
Registered: ‎06-01-2009
My Device: Not Specified

Re: Cannot login using Active Directory. Wrong LDAP servername in LOG.

RESOLVED

I managed to resolve my Active Directory authentication failures by adding my 'ldap' servers to my etc/hosts file.

un$%^&*in real.

RIM should hire me.

Still doesn't explain what is wrong with thier code and the inability to properly query my ldap. But the workaround ... works around....