Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 1
Registered: ‎12-10-2013
My Device: Z10
My Carrier: Sasktel

Error adding Z10 to BES

We have a BES 10 server (version 10.0.0a) with 18 Blackberry 10 devices joined to it. Yesterday I tried to add another and I have 6 CALS left on the server. Everything goes fine until I get to putting in the Windows password to access the account. I get an error saying:  There is no RPC service named Account:1386687959

The only thing that I can think of is that the new Z10 has Software Release installed. Is there a problem joining this new version to our older BES server?

I thought I could just bump our BES to version 10.1 to see if that would help, but when I try to install it says that BES is already installed, please uninstall before installing this version. I don't want to have to re-activate all 18 existing devices. I also thought I could get the new Z10 back to 10.1...but I couldn't seem to do that either.

Stuck between a rock and a hard place. Anyone have a solution?


Thanks, Michael

New Member
Posts: 1
Registered: ‎01-28-2014
My Device: z10
My Carrier: Telus

Re: Error adding Z10 to BES

Usually that means that activesync is not enabled for the user. Double check to see if it is enabled.
Guru III
Posts: 32,253
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry DTEK60, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Error adding Z10 to BES

make sure user is just a plain domain user and inheritence is enabled in AD


Click here to Backup the data on your BlackBerry Device! It's important, and FREE!

Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.

SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope

Want to thank me? Buy my KnottyRope App here

BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V

New Member
Posts: 2
Registered: ‎08-18-2014
My Device: Z 10
My Carrier: Airtel

there is no rpc service named account :1404906913

While change the password am trying add the new password am getting the error -there is no rpc service named account :1404906913 please need solution for this this configured with Zembra Mail service

Super Contributor
Posts: 278
Registered: ‎04-01-2008
My Device: Z30

Re: Error adding Z10 to BES



When you run this cmdlet, what does it give you back: Get-CASMailbox

'ActiveSync Enabled' needs to be set to true


See example below of my test mailbox:




Also, have you seen this KB: http://www.blackberry.com/btsc/KB35447

Don't forget to hit like if I resolved your issue! Smiley Happy