Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 10
Registered: ‎05-15-2013
My Device: curve 9300
My Carrier: orange
Accepted Solution

Error during first setup BES 10.1.0

[ Edited ]

Hello all


i have an issue on my first setup of BES 10.1.0 on WIndows server 2008 R2 french standard edition 


in log file: i saw that : 


CCertificateWrapper::InstallCertificate executed Return Code is [0]
<#03>[30000] (05/15 11:00:43.239):{0xC34} CCertificateWrapper::InstallCertificate executed, result is [0]
<#03>[30000] (05/15 11:00:43.239):{0xC34} CUbitexxCACertDataCon::Apply: Successfully installed the certificate.
<#03>[30000] (05/15 11:00:43.239):{0xC34} CCertificateWrapper:Smiley TonguearseCertificate executing - [C:\Windows\SysWOW64\certutil.exe -p "XXXXXXXX" -v "C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Service 10\Certs\ca.pfx"]
<#03>[30000] (05/15 11:00:43.551):{0xC34} CProcessWrapper::RunCommand: The exit code of the process for C:\Windows\SysWOW64\certutil.exe -p******** -v "C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Service 10\Certs\ca.pfx" is [0].
<#03>[30000] (05/15 11:00:43.551):{0xC34} CProcessWrapper::RunCommand: Successfully launched the process: C:\Windows\SysWOW64\certutil.exe -p******** -v "C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Service 10\Certs\ca.pfx"
<#03>[30000] (05/15 11:00:43.551):{0xC34} CCertificateWrapper:Smiley TonguearseCertificate executed Return Code is [0]
<#01>[10000] (05/15 11:00:43.567):{0xC34} CCertificateWrapper:Smiley TonguearseCertificate - The certificate line []
<#03>[30000] (05/15 11:00:43.567):{0xC34} CPasswordDataCon::Base64Encode succeeded
<#03>[30000] (05/15 11:00:43.567):{0xC34} CCertificateWrapper:Smiley TonguearseCertificate executed, result is [0]
<#03>[30000] (05/15 11:00:43.583):{0xC34} x509CertificateWrapper::AcquireCertificateByThumbprint certificate file path is []
<#01>[10000] (05/15 11:00:43.583):{0xC34} CCertificateWrapper::GrantCertificatePermissions: The certificate file name is empty.
<#03>[30000] (05/15 11:00:43.583):{0xC34} CCertificateWrapper::GrantCertificatePermissions executed, result is [486001]
<#01>[10000] (05/15 11:00:43.583):{0xC34} CUbitexxCACertDataCon::Apply: failed to GrantCertificatePermissions for CA certificate.
<#01>[10000] (05/15 11:00:43.583):{0xC34} CDataContainer:Smiley Very HappyoApplyImpl: UbitexxCACertDataCon failed to apply. Result: 487007.
<#03>[30000] (05/15 11:00:43.583):{0xC34} Step ApplyProduct failed
<#01>[10000] (05/15 11:00:43.583):{0xC34} [CInstallStepSeq::ApplyProduct]: Product application failed.


many thanks for your help

New Member
Posts: 1
Registered: ‎05-16-2013
My Device: Z10
My Carrier: ATT

Re: Error during first setup BES 10.1.0

[ Edited ]

I too have experienced this same error (US English install).  Initial process was upgrading BDS 10.0 only, no UDS or Studio installed.  Tried twice with same results. 


Uninstalled 10.0, restarted and tried installing 10.1 with the same results as above.  We're stuck and may call Blackberry.  One last effort will occur today, did a complete uninstall of anthing 10.0 or 10.1 we could find and cleaned out the registry and file system of BBRY stuff.  Restarted and installing 10.1 this morninig - will update with results.

Posts: 10
Registered: ‎05-15-2013
My Device: curve 9300
My Carrier: orange

Re: Error during first setup BES 10.1.0

i solved my problem with new install on server 2008 R2 English version

New Contributor
Posts: 9
Registered: ‎05-23-2013
My Device: Bold 9800
My Carrier: Vodafone

Re: Error during first setup BES 10.1.0

You can try the following workaround;


Install the english languagepack for your Serverversion (R2?/SP?)

Change System Language

Create a local Group "Authenticated Users"

Add your Installation-Account (BESAdmin?) to this group


Try again to install your Server.

Good Luck!!

New Member
Posts: 2
Registered: ‎05-16-2013
My Device: Z 10
My Carrier: Vodafone-DE

Re: Error during first setup BES 10.1.0

@Zille: Please, if you post this sollution remember, who was the "owner" of this information and has posted it first!

So please use a quotation next time or just post a Link to the solution but do not write it as it is your own knowlege!