Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

New Contributor
Posts: 5
Registered: ‎06-24-2013
My Device: 9900

Having Issues with e-mail after activating only on some accounts

So recently I installed a new BES 10.1.2 server (all components on one server)  


Our environment is Exchange 2010, so since I previously had besadmin user account created for BES 5.0, I just used bes10admin for the new server.  


Everything seems to be working correctly as my phone is set up on a Q10 and working fine.  However, there are 2 accounts that aren't working properly when we activate on a new phone. 


I created the e-mail profile(same as mine) and assigned it to the user, they activate and don't get any errors, once the activation is complete they don't have any e-mails in their hub.


I checked the send-as and full access permissions on their accounts and for some reason just their accounts don't have bes10admin added in there.  So I just manually added the user.  I deleted the user from bes bds and wiped the work space and re-activated.  Still the same issue. Nothing I seem to do will fix this particular issue with just these 2 users (one unfortunately is my boss).


I know when we are creating the bes10admin permissions on the exchange database we type the following commands. 


Add-RoleGroupMember "View-Only Organization Management" -Member "bes10admin"


Get-MailboxDatabase | Add-ADPermission -User "BESAdmin" -AccessRights ExtendedRight -ExtendedRights Receive-As, ms-Exch-Store-Admin, ms-Exch-Store-Visible



When I enter these commands, they just come with a warnings stating it has already been done. 


The bes10admin comes onto newly created accounts and activation works fine. 


How is it possible to run these commands just on a single user account to make sure this user is getting all permissions it needs? 


Thanks for the help, 







New Contributor
Posts: 5
Registered: ‎06-24-2013
My Device: 9900

Re: Having Issues with e-mail after activating only on some accounts

Hey Everyone, 


Found out the reason why it wasn't working. 


I went to the root of my domain and confirmed the send as permission was there then proceeded to check my security permissions on my account that worked, everything was there. 


Went to the two users that weren't working and low and behind, the check box for inheritable permissions was unchecked. 


Fixed that and within about 2 minutes I got an e-mail saying that he was now receiving mail.


All is good.


Hey Knotty Rope - Long time admirer, first (now second) time poster!  You've saved my @ss a few times.  Thanks for your commitment to these forums, for everyone that actually posts issues, there are 50 who just search and find the answer thanks to you and everyone on here's hard work.