Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Contributor
Posts: 13
Registered: ‎11-02-2009
My Device: Not Specified

IEMSTEST Fails Send as

I have 5 users on my BES 5 server and all are functioning with out a problem. The only thing is when I run IEMSTest I get No Send As. But these users are able to send email. All my permissions have been set since we have been running BES 4.1 and nothing has changed on our Exchange server.

 

BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Version 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - BESAdmin

Test User9: Opening message store using
        /O=Group IV/OU=NY/cn=Recipients/cn=tuser9
        /O=Group IV/OU=/cn=Configuration/cn=Servers/cn=MailServer/cn=Microsoft Private MDB
Test User9: Mailbox opened successfully
Test User9: Root Folder opened successfully
Test User9: Folder created successfully
Test User9: Test folder deleted successfully
Test User9: MAPI test completed successfully
Test User9: CDO Server Name: MailServer
Test User9: CDO Mailbox DN: /O=Group IV/OU=NY/cn=Recipients/cn=tuser9
Test User9: CDO logon successful
Test User9: Get default calendar folder successful
Test User9: Get calendar folder name successful: 'Calendar'
Test User9: CDO test completed successfully
Test User9: No Send As permission for the {Domain\besadmin} account operator.

Retired
Posts: 616
Registered: ‎03-25-2009
My Device: BlackBerry Curve 9360
My Carrier: Bell

Re: IEMSTEST Fails Send as

Out of curiousity, is your BESadmin account a domain admin?

______________________________________________
The only stupid question is the one you don't ask before you reboot the BES.
Contributor
Posts: 13
Registered: ‎11-02-2009
My Device: Not Specified

Re: IEMSTEST Fails Send as

Yes, besadmin is a domain admin

Contributor
Posts: 26
Registered: ‎04-28-2009
My Device: Z10 - Bold 9900 - Porsche P'9981
My Carrier: Telekom.de - Vodafone.de

Re: IEMSTEST Fails Send as

[ Edited ]

BESAdmin service account should not be a domain admin. Remove this group membership for that account and reconfirm that the BESAdmin has got the Send As permissions assigned through Active Directory.

But if your users are all able to send messages from their BlackBerry devices without any issues, you shouldn't be too worried about the IEMSTEST failure message.

Retired
Posts: 616
Registered: ‎03-25-2009
My Device: BlackBerry Curve 9360
My Carrier: Bell

Re: IEMSTEST Fails Send as


mystics7 wrote:

Yes, besadmin is a domain admin


 

That would explain why you didn't need to set the Send As permission in AD. Domain Admins are automatically granted the Send As right on all user accounts. If your besadmin account is a domain admin, then it has the right implicitly. This is great news, except for the fact that by default, the Exchange Send As permission is revoked from Domain Admins. This can break calendaring from the device to the mailbox.

 

There are tweaks that you can make to allow for this type of set up to work, but in general, we recommend having the besadmin as a normal Domain User, and allowing it to have the AD Send As right for the users.

______________________________________________
The only stupid question is the one you don't ask before you reboot the BES.