Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
Posts: 9
Registered: ‎09-17-2009
My Device: Not Specified

Problem in retrieving email or pin using Http Headers (via rimpublic.property)

We recently have upgraded our BB software from 4.6 to 5.0 and since then, our application on the BB is no longer working.

We rely on the email address returned from the http_handler property "application.handler.http.header" to authenticate users and this seems to be not working for some reason.

 

I have checked  C:\Program Files\Research In Motion\BlackBerry Enterprise Server\MDS\Servers\Instance\config\rimpublic.properties ) file and the setting seems to be fine:

 

[HTTP HANDLER]

application.handler.http.logging = true

application.handler.http.header = email,pin

 

Also restating the MDS service didn't help.

 

Any idea on how to fix this will be greatly appreciated. Thanks.

 

New Contributor
Posts: 2
Registered: ‎05-22-2010
My Device: Curve
My Carrier: at&t

Re: Problem in retrieving email or pin using Http Headers (via rimpublic.property)

I'm looking for this answer too. Did BES 5 drop this feature?

New Contributor
Posts: 3
Registered: ‎04-21-2008
My Device: Not Specified

Re: Problem in retrieving email or pin using Http Headers (via rimpublic.property)

Hi,

 

try to add this in [logging] not in [http_handler]

 

 

Regards,

Steffen

Visitor
Posts: 1
Registered: ‎08-25-2010
My Device: Not Specified

Re: Problem in retrieving email or pin using Http Headers (via rimpublic.property)

Hi folks,

 

We want to migrate from BES 4.1 to 5.0 and this item is a critical point for us. BES 5.0 really drop this feature?

Highlighted
New Contributor
Posts: 2
Registered: ‎09-21-2010
My Device: Not Specified

Re: Problem in retrieving email or pin using Http Headers (via rimpublic.property)

Hi,

 

Were you able to resolve this issue. I also have an similar issue.

 

Thanks

Itzseema