Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Contributor
Posts: 25
Registered: ‎08-24-2011
My Device: 8520
My Carrier: vodafone

Problems deploying package to devices

[ Edited ]

Hi all

 

We have just moved to BES 5.0.3 and i am having problems deploying any app to devices. I have done the following:

 

App the zip file (google maps and ocs)

Created seperate software configs and added the apps to these (wireless and required)

Added the software config to 3 users

Changed the job schedule settings to 1min deployment

 

Network share from the server created with everyone full access (as a test)

Specified the path under: BlackBerry Administration Service application shared network drive

A Shared folder is created with the Applications folder with the further subfolders for ocs and googlemaps. The correct files are generated

 

Manage deployment jobs only shows some IP policy deliveries and completions. No applications

 

Next: Nothing happens

 

I have used the following as guides:

 

http://btsc.webapps.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB03748

 

http://www.adamphones.com/technical-support/pdf/BES_Documents/Deploying%20Applications%20Wirelessly%...

 

 

Any ideas where i am going wrong? Where and what do i need to check? Vodafone tell me its a proxy issue:

 

http://btsc.webapps.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB27629

 

The log dosnt have the specified proxy errors. Also should there be something in manage deployment jobs?

 

Spent the whole day on this so any help will be hughly appreciated.

 

Looking into the following tomorrow morning:

 

http://btsc.webapps.blackberry.com/btsc/viewContent.do?externalId=KB25252&sliceId=1

 

 

Guru III
Posts: 32,127
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Problems deploying package to devices

if device XML is not up to date it can fail as well.

KB13589 - How to update the device.xml and vendor.xml files

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


Contributor
Posts: 25
Registered: ‎08-24-2011
My Device: 8520
My Carrier: vodafone

Re: Problems deploying package to devices


knottyrope wrote:

if device XML is not up to date it can fail as well.

KB13589 - How to update the device.xml and vendor.xml files


Does it matter we are on 5.0.3 as the article refers to only for BlackBerry Enterprise Server 5.0 to 5.0 SP2?

Forums Advisor I
Posts: 724
Registered: ‎07-02-2008
My Device: Z10
My Carrier: Fido

Re: Problems deploying package to devices

[ Edited ]

Does your IT policy allows download of third party applications?

Contributor
Posts: 25
Registered: ‎08-24-2011
My Device: 8520
My Carrier: vodafone

Re: Problems deploying package to devices

I am deploying a specific blank IT Policy for this.

Still no luck.

Next enabling tracing on the server to detect what its doing to the ISA.
New Contributor
Posts: 8
Registered: ‎11-18-2010
My Device: Not Specified

Re: Problems deploying package to devices

I've been having a similar issue with my environment.  I started this process of attempting to deploy the software with 5.0.2

I'm now at 5.0.3 MR3

 

What I learned is that with the newer BES versions you can't just update the XML files yourself.  What I attempted to do was download and update those files with the latest ones and then update the SQL table with them... didn't work.  I tried sharing the Vendor and Device XMLs out and everything.  The process is that the BES has to go to RIM to get the Vendor and Device XMLs and it queires for updates something like once an hour or something... the BES then updates the SQL table with the information.  That process is different in the newer versions as you used to be able to manually update the SQL table...

 

What you can try to do is to download the newest XMLs then check the version number of them.  To compare the version of the Vendor.xml and Device.xml files to the database log into your SQL cluster and select your databse.  Run a query against like this:

SELECT [DeviceXML], {VendorXML] FROM [dbo].[GlobalSettings]

Compare.

 

To view where the SQL Database is getting it's Vendor and Device XML files from do:

Select * from BASTraits Where PlugInId=0 and TraitId=36;

Select * from BASTraits Where PlugInId=0 and TraitId=37

Note the Value.

 

You can attempt to host or share out the files by placing them on your BAS (in order to use this method you have to give the BAS's LOCAL USERS group WRITE access to the path hosting the files)  and manually pointing the SQL database to it by running this on your database:

Update BASTraits Set Value = 'FILE:///C:/<PATH_TO_FILE>/DEVICE.XML' Where PlugInId= 0 and TraitId=36;

Update BASTraist Set Value = 'FILE:///C:/<PATH_TO_FILE>/VENDOR.XML' Where PlugInId=0 and TraitId=37

 

I know that you're doing a blank IT Policy but the BES Policies are similar to a GPO in that the "Default" policy has settings in it when the Environment is created, comes slightly precanned.  There are some settings that have to be un-done.  Very similar to the default domain policy you get on the creation of the domain...

 

I'm still fighting with this myself today... Let me know if t you stumble on anything... the other way to publish out the vendor and device is to host it on a web server/IIS...

 

New Contributor
Posts: 8
Registered: ‎11-18-2010
My Device: Not Specified

Re: Problems deploying package to devices

Contributor
Posts: 25
Registered: ‎08-24-2011
My Device: 8520
My Carrier: vodafone

Re: Problems deploying package to devices

What i have done is download the xml files just after 10 past the hour from:

 

http://btsc.webapps.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB13589

 

Then placed the files in the following location:

 

\\<servername>\BBAppShare\AppLoader

 

And wholla, i and others received the packages. So obviously some issue with the proxy. Port 443 has been allowed through but obviously something still isnt right.

 

Highlighted
Contributor
Posts: 25
Registered: ‎08-24-2011
My Device: 8520
My Carrier: vodafone

Re: Problems deploying package to devices

Re: Problems deploying package to devices
 

http://btsc.webapps.blackberry.com/btsc/search.do?​cmd=displayKC&docType=kc&externalId=KB22777

How to download and update the XMLs for 5.0 to 5.0.3

 

 

 

I know this