Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Highlighted
New Contributor
Posts: 4
Registered: ‎11-29-2013
My Device: 9360
My Carrier: T-Mobile
Accepted Solution

Secure Work Space App refusing server certificate

Hello all together,

 

First of all - our environment:
BES 10.2.2 which got upgraded from 10.1.3 to 10.2 and then 10.2.2 recently
Local SQL Server Express 2012
Exchange Server 2010 SP2
BlackBerry 10 devices working flawlessly

 

Problem:
We are trying to get UDS with Secure Work Space working. Unfortunately without luck in the end.
Tested are a Samsung Galaxy S4 (Stock Android 4.3) and a Sony Xperia Z (Stock Android 4.4.2).

On BES 10.1.3 we were not able to get Secure Work Space working on the Samsung.
It was exiting with (freely translated) error message "Work Space-Error - Can't connect to Work Space. Invalid server certificate". And the app quits or locks up the device for a few seconds before bringing back the Android stock launcher.
(Original German: "Work Space-Fehler - Kann Work Space nicht aufbauen. Ungültiges Server-Zertifikat")
The Sony was working!

 

Because of ...
"On an Android device, if the BES10 Client declined an SSL certificate, when the user tapped the BES10 Manager app icon,
a "Work Space Connection Error" displayed. When the user tapped the OK button and then tapped the BES10 Manager
app icon again, the same message reappeared. (DT 7846413)"
... mentioned in the 10.2 release notes we planned an evening for upgrading and went from 10.1.3 to 10.2 and 10.2.2 afterwards.
No problems appeared through the upgrade.

BUT: Now the Sony isn't working any more either. It shows the same message mentioned above.


Devices are installing the certificate from de.bbsecure.com before activation and activating through BES10 Client app without any problem. Work Space MGR, Secure Work Space and Office app are getting installed as required.
Users/Devices have been deleted and readded. Nothing helped yet.

The certificate served through https://de.bbsecure.com/T... is matching the one used by IIS's CommunicationModule.
The same certificate is noted as "Issued by" for the "RIM BUDS Core SSL Certificate" in certmgr.msc.
Plus its noted in C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Service 10\Certs\BES10\keystore.listing.txt for UDS.
So everything seems fine.

 

Long story short:
What might cause the Secure Workspace App to refuse the server certificate?
How can I debug this? What logs might throw more information? Either to help resolving or you understanding the problem :-)

 

Many thanks in advance!

 

Greeting from Germany

Björn

New Contributor
Posts: 4
Registered: ‎11-29-2013
My Device: 9360
My Carrier: T-Mobile

Re: Secure Work Space App refusing server certificate

Okay, I ran through the process for setting up a new certificate for the Communication Module[1] again.

Both, iOS and Android, are working flawlessly now.

 

[1] Page 124: http://docs.blackberry.com/en/admin/deliverables/63518/BES10_v.10.2.2_Configuration_Guide_EN.pdf