Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Highlighted
Contributor
Posts: 30
Registered: ‎10-12-2010
My Device: Not Specified

Secure Work Space - Error: PIN not set

I setup my first iOS Work Space device today.  The first time I setup, the Work Space Application prompted me to create a password, which I did.  Then I did a test run on removing the work space via the management console.  After removing, and rebooting the phone, I tried activating again.  Now whenever I open Work Space I get following:  

 

This application requires a secure workspace in order to run. Please contact your IT admin for the provisioning of your secure workspace. Error: PIN not set.

 

First off, I can't find where or how to "set the PIN".  I tried activating with a different user account, and that didn't help either.    I attached an image of the error.

 

Secure Work Space

Retired
Posts: 91
Registered: ‎05-17-2013
My Device: BlackBerry Z-10
My Carrier: Rogers

Re: Secure Work Space - Error: PIN not set

Hello conito68;

 

Thank you for the question.

 

My understanding is that you removed the workspace application, but did not do a remote wipe or deactivate the workspace.

 

Were you prompted to reboot the device due to the change you implemented, or did you reboot as a precautionary step?

 

Is the version of IOS you are using supported by the BlackBerry Enterprise Service 10.1?

 

Are you able to select the BlackBerry 10 client on the device and select deactivate?

 

Have you tried removing the three applications which are downloaded during activation?

            Reload the applications

            Start a new activation

 

Let us know if you have any further questions regarding this specific request.

 

 

 

MAD-VIKING
Contributor
Posts: 30
Registered: ‎10-12-2010
My Device: Not Specified

Re: Secure Work Space - Error: PIN not set

I have actually recreated this issue in 2 situations. 

1. Remove device and do "work space wipe" in BES

2. Remove device by selecting "dectivate device" in phone.

 

I'm running iOS 6.1.3, which is the current version.

 

All 3 applications have been removed from the device. I have also tried rebooting the phone.  The only way I'm able to activate a workspace on the same device after a deactivation is being doing a full device wipe.

New Member
Posts: 2
Registered: ‎08-02-2013
My Device: z10
My Carrier: Singtel

Re: Secure Work Space - Error: PIN not set

I had this problem as well but I got it fixed myself. Below are the steps:

 

  1. Select the iPhone from UDS, then "Delete only work data".
  2. Deactivate my account from iPhone BES10 Client.
  3. Delete all the apps for BES10 from the iPhone.
  4. Make sure your iPhone is removed from the UDS.
  5. Perform another new activation for the iPhone. You don't have to re-send the activation mail as it is still valid.
  6. Go through the steps provided from the activation mail.
  7. Everything should work by then.

Cheer!