Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Guru III
Posts: 32,114
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry PRIV, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Server Stops Sending Email after 24-48 Hours

He is running SQL express and confirmed the number of agents in the registry.

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V


Contributor
Posts: 16
Registered: ‎10-01-2009
My Device: Not Specified

Re: Server Stops Sending Email after 24-48 Hours

I am running SQL Express 2005. 

 

This new server is a new install of 2003 with BES 5.0.  I then installed the BES Transport and moved the users from my older server runing BES 4.1.7.

 

It took a service call to BB to get the transport to work but all the users moved over fine. I have sence disabled all the BB services on the other machine, removed it from the domain, and wiped it clean.

New Contributor
Posts: 4
Registered: ‎09-14-2009
My Device: Not Specified

Re: Server Stops Sending Email after 24-48 Hours

Did anyone ever get to the bottom of this issue? I'm seeing the exact same symptoms on a newly-built instance of 5.0.1 on Server 2008 SP2.

 

I have a case open with RIM but we seem to be going around in circles Smiley Sad

 

--Nick

New Contributor
Posts: 3
Registered: ‎07-10-2009
My Device: Not Specified

Re: Server Stops Sending Email after 24-48 Hours

Hi All,

 

I'm experiencing the same issues on my BES.

 

Version is BES 5.01 running on a Windows Server 2008 SP2 for Exchange 2007 SP1

 

If anyone find a resolution that doesn't involve retarting every few days, please post for us Smiley Happy

 

Many Thanks.

 

 

New Contributor
Posts: 5
Registered: ‎02-05-2010
My Device: Tour
My Carrier: Bell

Re: Server Stops Sending Email after 24-48 Hours

The fix for me was to update to the newly released version of Messaging API and CDO from microsoft.  you need to first take bes offline, uninstall the old build, and install the new one.

 

http://blogs.msdn.com/b/stephen_griffin/archive/2010/04/29/updated-mapi-download-fixed-crashes.aspx

 

New Contributor
Posts: 3
Registered: ‎10-10-2011
My Device: None
My Carrier: Verizon

Re: Server Stops Sending Email after 24-48 Hours

I know this is and older topic but I am currently experiencing EXACTLY the same issue except i have one agent connected to a 2010 exchange and the other connected to 2007 exchange.  Only the 2010 is the one crashing every night. 

 

I have worked with support on upgrading to 5.0.3 mr4 and upgrading the CDO to 6.5.8211.  Support has also directed me to make entries in my host file for a single CAS but that has not helped either. 

 

It appears this all started happening about 2 weeks after we did rollup 5 patch to our 2010 exchange environement. 

 

Does anyone have some other suggestions on fixing this?  I know a scheduled task can restart the services every night but man i just cant stand the sound of doing that. 

Highlighted
Retired
Posts: 616
Registered: ‎03-25-2009
My Device: BlackBerry Curve 9360
My Carrier: Bell

Re: Server Stops Sending Email after 24-48 Hours

That's interesting that it's confined to one agent.

 

A few more environment details might help.

- Which mail server is the BESAdmin account (or whatever service account you use) on?

- Just to clarify, you mentioned that you upgraded CDO. Does that mean you installed the latest MAPI/CDO 1.2.1? Not just CDO 1.2.1?

- Any other changes in those two weeks that you can think of? Did you move any users from Exchange 2007 to 2010?

- When do the outages occur? Are you able to narrow it down to a specific time of day or is it sporadic in a 24-48 hour period?

- When the outage happens, are the services stopped (are they crashing?) or do they still show as "Running" under Windows services?

- We need to narrow it down a little. It sounds like the agent is crashing so maybe we can look at the logs to confirm that Anything in the logs? If it is the agent crashing, you might want to start with the CTRL log to see if you can narrow it down to a time and possibly get an error message. Then look at the relevant MAGT log to see what's happening at that time. You might see things like "delayed notifications" or maybe even an all out stack dump. Pay attention to whether it happens during business hour or in the middle of the night.

______________________________________________
The only stupid question is the one you don't ask before you reboot the BES.
New Contributor
Posts: 3
Registered: ‎10-10-2011
My Device: None
My Carrier: Verizon

Re: Server Stops Sending Email after 24-48 Hours

Thank you for the response but just got off the phone with support and they believe that a users address book might be causing the issue!!  We looked at logs as far back as 2 weeks and the same users name showes up right before every memory dump. 

 

Support asked to delete the user and look at there address book for invalid characters in contacts names. 

 

Just before i deleted the user my messaging agent was sitting at 700mb worth of usage and climbing.  I deleted the user and immediatly it dropped to 30mb and has been sitting at that for about 45 minutes now.  I am going to continue to monitor but i believe this might be my problem because in the BAS this user had  "failed delivery" out beside the name.