Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
New Contributor
Posts: 3
Registered: ‎11-25-2010
My Device: Torch 9700
My Carrier: Orange

Universal Device service AD Connections

Hi, I have successfully installed the Universal Device service but am having trouble adding users from the directory. I think I may have two issues

 

1) In the documentation for the AD settings it says add in the hostname Or IP Address as “LDAP://server_name>”

but on the AD settings on the UDS it says the URL - does it mean the same thing? Or should I be adding a URL there? If so what is the format for the URL

2) All of our email accounts sit in a single domain but that acts as a service domain for other trusted domains. Therefore each user in the email domain is disabled. Should UDS still find the users?

 

Many thanks

 

Matt

Contributor
Posts: 17
Registered: ‎04-19-2012
My Device: Curve 9300
My Carrier: 02

Re: Universal Device service AD Connections

Matt,

 

The format of the Directory URL is LDAP://

 

For example....

 

Username: mydomain\me

Password: %mypassword%

Directory URL: LDAP://mydc.mydomain

 

You should then be able to go to create user and search your directory.  That is definately the correct format, i have just checked my configuration.

 

Ta

 

Paul

 

New Contributor
Posts: 2
Registered: ‎08-11-2009
My Device: Not Specified

Re: Universal Device service AD Connections

Use LDAP://servername:3268 if using a Global Catalog, good if GC is in root domain and you have many child domains.

Highlighted
Contributor
Posts: 18
Registered: ‎04-13-2012
My Device: 9790
My Carrier: vodafone

Re: Universal Device service AD Connections

Adding a user, selecting "Directory", filling in a name, clickin on search and get this error:"The system encountered an error and could not search the user directory"

 

I waited more than 1 hour. anyone knows which log i should check to find what's going wrong?

 

thanks

Developer
Posts: 411
Registered: ‎04-04-2012
My Device: BlackBerry Z30/Z10/Z10LE/Q10/PlayBook

Re: Universal Device service AD Connections

I am having the same problems. I am getting a "error occured and the resquested action could not be completed" when I click on the "Test" button.

 

domain\me

%password%

LDAP:\\server

 

server is a Windows 2008 R2

BlackBerry Employee
Posts: 750
Registered: ‎05-15-2008
My Device: Z10
My Carrier: Rogers

Re: Universal Device service AD Connections

UDS will assume port 389 if you don't specify a port. You can see more information about what is failing in the Core log.