Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Enterprise Service 10

Reply
Highlighted
Contributor
Posts: 34
Registered: ‎10-07-2010
My Device: Z10
My Carrier: KPN

iPad secure work space apps keep saying "Work Place connecting..."

Hi all,

 

I have a situation with (only) iPads activated on a BES 10.1.3 environment.

 

When I'm done activating and installing the work apps, I try to setup the Email config.

As soon as I entered my Exchange information (email, user name and password) and select the Save button, it tells me it failed to validate. After the 5th attempt it accepted the (same) credentials and opens the email app.

There are no emails shown and it keeps telling me every 5 sec Work Space connecting...

Just like in KB: http://www.blackberry.com/btsc/KB33605

In the meanwhile I open the (personal) browser, saw a BES10 with a big OK button, so I tapped it, it opened the BES10 client app. I get a message that some parts are updated, like policy, profile etc. for three times.

When I got back to the work email app, it shows my emails and I'm able to send emails, but I still get the annoying  Work space connecting message every 5 sec. I've send myself an email, but after ten minutes it still doesn't show up on the iPad.

 

If the mentioned KB article would be the issue, shouldn't I have the same issues on iphones, android phones and tablets?

I don't have this issue on these platforms and I activated a few of these different devices. Only the iPad is experiencing this behaviour.

 

I have no clue how to view the iOS console log and what I believe from some searches I did on it, it's not that simple.

 

I would like to know if others are experiencing this, or if you have any information that could help us identify the cause, it would be really appreciated.

 

Thanks!

Contributor
Posts: 34
Registered: ‎10-07-2010
My Device: Z10
My Carrier: KPN

Re: iPad secure work space apps keep saying "Work Place connecting..."

My colleague was able to get the console log of the iPad and we noticed that there is an issue with a certificate.

The only thing is, we don't know which certificate it's talking about and expired on 150820173039Z, is that 15th of august 2017 ??

 

Oct 10 09:27:54 iPad Work Connect[88] <Warning>: Heartbeat failed on timeout, attmept to restart RIM VPN

Oct 10 09:27:54 iPad Work Connect[88] <Warning>: [WARN] - _process_cmd: Received command to stop

Oct 10 09:27:54 iPad Work Connect[88] <Error>: unable to open state file for reading

Oct 10 09:27:55 iPad Work Connect[88] <Warning>: [ERROR] - verify_cert_cb: certificate expired on 150820173039Z

Oct 10 09:27:55 iPad Work Connect[88] <Warning>: [ERROR] - verify_cert_cb: certificate expired on 150820173039Z

Oct 10 09:27:55 iPad Work Connect[88] <Warning>: [ERROR] - verify_cert_cb: certificate expired on 150820173039Z

Oct 10 09:27:55 iPad Work Connect[88] <Warning>: [ERROR] - verify_cert_cb: unable to verify leaf cert signature

Oct 10 09:27:56 iPad Work Connect[88] <Warning>: [WARN] - process_fd: no data in buffer for fd=68

Oct 10 09:27:56 iPad Work Connect[88] <Warning>: [WARN] - process_fd: no data in buffer for fd=68

Oct 10 09:27:59 iPad Work Connect[88] <Warning>: Heartbeat failed on timeout, attmept to restart RIM VPN

Oct 10 09:27:59 iPad Work Connect[88] <Warning>: [WARN] - _process_cmd: Received command to stop

 

About every 5 sec we see the message Heartbeat failed on timeout, attmept to restart RIM VPN, which indicates the continously message Work Space connecting...