Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

New Contributor
Posts: 3
Registered: ‎09-17-2009
My Device: Not Specified
Accepted Solution

8130 GPS mot working

I have an 8130 with 4.5 loaded (and reloaded) on it but the GPS does not work at all.  Virgin Mobile with a data plan.  I cant even get lat and long.  When it follow the instructions for "get you gps location" and press the menu key refresh gps is not even an option (all I get is "close"  I have done all the things in the "cannot use GPS technology" help file and still no joy.  When I try it with Nav4All I get the mesaage "no GPS connection"  Google maps does not work either.  Th option is set to "device gps"
Posts: 96,070
Likes: 24,627
Solutions: 6,422
Registered: ‎04-01-2008
My Device: Passport • Z30 • Z10 • Torch9850 • Playbook
My Carrier: Verizon

Re: 8130 GPS mot working

On your CDMA xx30 model BlackBerry, do this:


Go to the Options icon > Status


From the Status screen, on the keyboard type "test" (without the quote marks!).


You will see a Device Self Test Screen. Click the Menu Key and choose Start. You will a list of tests. The bottom test should be GPS, check it and click Menu > Run. Be sure GPS location is turned on. Go outside with no obstructions or tall buildings around or above you. click the trackball and click start fixing. is should do a test. let it do its thing and it should tell you a location coordinates.

1. If any post helps you please click the Like Button below the post(s) that helped you.
2. Please resolve your thread by marking the post "Solution?" which solved it for you!
3. Install free BlackBerry Protect today for backups of contacts and data.
4. Guide to Unlocking your BlackBerry & Unlock Codes
Join our BBM Channels (Beta)
BlackBerry Support Forums Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
New Contributor
Posts: 3
Registered: ‎09-17-2009
My Device: Not Specified

Re: 8130 GPS mot working

Thanks for your prompt reply.  I can get to the status screen no problem but I can't type test ot anything else there.  The info is read only and showw signal, battery, file free etc
New Contributor
Posts: 3
Registered: ‎09-17-2009
My Device: Not Specified

Re: 8130 GPS mot working

I loved the Pearl for a lot of reasons but gave up on it beacuse of Virgin Mobile Canada's hobbling of the Blackberry GPS functionality.  First they told me that I needed a data plan to get the GPS working.  If that were true all the handheld GPS units that are not cell phones would not work.  Nav4All which uses map data stored on the memory stick and the internal GPS gave me a "no GPS signal" message. Even google maps (which uses cell tower triangulation instead of GPS) does not work with Virgin.  When I downloaded it directly to my phone I got a message saying "Google maps does not work on your 8130 phone, use the web version instead. When I pressed them for more tech support I was told that "we can't gaurantee GPS will work on your phone"


The only good news is that I got to return the phone and cancel the contract without penalty.  Virgin allowed me to return the phone because I met their restrictive return conditions of within 20 days and less than 20 minutes talk time.

New Member
Posts: 1
Registered: ‎01-20-2010
My Device: Pearl 8130
My Carrier: Virgin Mobile Canada

Re: 8130 GPS not working

Thank you very much for the GPS Test walk thru. Did as you suggested. I had to type [ 2,1,A,S,2 ] to spell out test.

Then I went outside and did the GPS test. The first try didn't work. The second try was the same. But third time was a charm. I got my GPS location and subsequent info. 


I have been trying to use Geocache Navigator. The program worked when I first  installed it, but it didn't have any GPS functionality. 


Once I had successfully tested the GPS location fixing, Geocache Navigator worked like a charm.


Thanks again JSanders


Smiley Happy

New Member
Posts: 1
Registered: ‎03-30-2010
My Device: 8330m
My Carrier: Cricket

Re: 8130 GPS mot working

On My BB 8130 Pearl, I actually had to type 21aa2 on the status page, because it's not a full QWERTY keyboard on the 8130. That combination of keystrokes equals 'test'.

New Contributor
Posts: 4
Registered: ‎04-02-2010
My Device: 8350i
My Carrier: nextel

Re: 8130 GPS not working

hello i have the same problem in my curve 8350i, the only problem its when i got to the status screen and type test GPS doesn't shows. does anyone know what should i do???