Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 6
Registered: ‎10-24-2010
My Device: Curve 9300 3G
My Carrier: Airtel

9300 DEAD... SOS..!!



I had updated my 9300 with the latest  OS6 (9300jAsia_PBr6.0.0_rel3049_PL6.6.0.246_A6.0.0.706_Bharti_airtel_Limited).


Post this the device was working fine.


Unfortunately, my battery died on me during a regular usage. I plugged the charger and thought that device was charging. I restarted the device. And it went dead.


It has been six days, since. And I have tried almost everything possible.


Fortunately I have another 9300 in the house and I changed the battery to check if it was battery problem. The answer is no.


I changed the charger to check if it was a charger problem - answer is no.


I tried using JL_Cmder v1.9.0 to wipe. - i guess its unsuccessful. the program gets over in less than 30 seconds. device is not recognised. the red led is not blinking at all. not even for 30 seconds as mentioned in some threads.


i tried to reset the power by alternatively pressing the end call and receive call buttons - unsucessful.


i tried to re-install the OS using app loader. the device is not getting recognised in pc. nothing comes in the dropdown. 


Some more info: Device is 2 years old. Battery is perfectly fine. (Used it in the other 9300). Currently, its as good as a paper weight. Red LED is also dead.

Am I missing something??


Would really appreciate if someone could guide me!!

Super Contributor
Posts: 298
Registered: ‎06-10-2012
My Device: Curve 9360

Re: 9300 DEAD... SOS..!!

Hello devbrat


Have a look at the link, I see you tried the end call and call button fix .......but just incase you tried with the battery inserted first. Then refer to the link also there is method Rim uses to address jvm error 517. Its the second post with where you reload Os without the battery.

If all else fails then download "blackberry easy flash tool" will try and load Os with no jvm without having to manually type the commands in command prompt.

Good luck