Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Reply
New Contributor
Posts: 3
Registered: ‎07-20-2012
My Device: a

9700 browser reverts to start page whenever I try to load another page

Bold 9700 running 6.0.0.248 with T-Mobile USA.

 

I recently downgraded to 6.0.0.248 due to Wi-Fi problems, which were resolved by the downgrade.  The browser worked perfectly fine.  Then I restored my full backup and apps, but now the browser stopped working.

 

It opens, shows the start page (bookmarks/history), and when I try to load any page, including a page hosted within my LAN, it starts to load, saying "requesting", then immediately goes back to the start page.  Also, if I open a second tab and try to load a page there, it goes through the same process, but when it returns to the start page the second tab is closed, suggesting that it's restarting the browser.

 

I don't currently have data service, but the same problem still occurs with Wi-Fi off, rather than telling me "web browsing isn't currently supported by your plan".  Pinging local and remote IPs and the router works fine as well, returning all 4 packets successfully.

 

I'm rather certain that this is due to restoring a full backup, which included some bad settings, but I'm at a loss for which it could be at this point.  I've checked everything I know to check and it seems fine, but I must be missing something.

 

Can anyone offer some suggestions?  I'm thoroughly sick of browser problems with this phone.

New Contributor
Posts: 3
Registered: ‎07-20-2012
My Device: a

Re: 9700 browser reverts to start page whenever I try to load another page

[ Edited ]

Update:

After trying several configurations of settings which seemingly caused it to work or not, I just now discovered that it only works when plugged into the USB cable with desktop manager.

 

What doesn't make sense is why the browser would "crash" completely rather than just giving an error message.

 

Also, if plugged into the computer, with Wi-Fi on, it works, and with Wi-Fi off and only mobile network on, attempting to go to google redirects me to a T-Mobile page which loads very slowly (as if it was on 2g), suggesting that it's using the available networks, but still somehow can only use them when it's plugged in.

 

Any ideas?

Highlighted
New Contributor
Posts: 3
Registered: ‎07-20-2012
My Device: a

Re: 9700 browser reverts to start page whenever I try to load another page

Anybody?  This is getting old