Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

Trusted Contributor
Posts: 138
Registered: ‎07-25-2011
My Device: Z30, Torch 9800, Playbook
My Carrier: Telus

AW version installation story on a Torch 9800

This story began when I received a message that AW version was available. I have a Torch 9800 with software version and for the last 2 years every time I tried to install a new version of AW I ran into icon issues, either by clicking the AW icon it did not open the AW start up page or the icon could not be found. So I was curious what happen this time.


After I downloaded the new version and clicked the AW icon the app did not open. I checked the 'Application Management 'info and alas: AW was installed but already running showing CPU time had accumulated, i.e. AW was stuck in a loop.


I then tried to recover by pulling the battery a few times and uninstall/reinstall the AW software but to no avail. (This often is a quick fix but mostly not for a Torch 9800).


The only way I knew how to solve this issue was to wipe the phone but with an 'auto restore' feature for my current data. While this method wipes one's phone, i.e. it removes first all current device information and applications it is smart enough to reload all your device info and all apps including the paid apps later automatically.


I call this method 'auto restore'. A classic wipe leaves your phone with no data as suggested in other threads but then one has to reload  the backup data file  by hand to restore stuff but it does not restore your apps automatically and is quite cumbersome.


 Here are my initial conditions:

I have the newest DTM (Desktop Manger Software) installed, e.g. version

I have a copy of my current device software on my (Windows XP) PC

I made a backup file of my current data and apps

I had previously installed a valid ID 

I installed the newest AW version, e.g. (but with issues)


Here are my actions:

1) I selected 'Update' on DTM under 'Device' on the main DTM screen getting this message:


An updated BlackBerry Desktop Software component must be installed before you can continue.


2) I selected 'Install'


Windows Installer Window popped up.


Please wait while Windows configures BlackBerry Device Software Updater.


Existing BlackBerry software has been detected on your computer and must be closed before proceeding. Disconnect your device and click OK to close the applications. Otherwise click Cancel to stop the installation.


3) I disconnect my phone and clicked OK.


DTM shut down and then restarted after the BlackBerry Desktop Software component installation was complete.


4) I reconnected my phone and selected again 'Update' on DTM under 'Device' on the main DTM screen getting this message:


There are no BlackBerry Device Software updates available.


5) I unchecked 'Keep me subscribed to email notifications' and selected 'View other versions'. I then selected 'Install' using the currently installed version with the default check mark.


DTM checked again for updates but now I got an 'Update Option' box with 2 default check marks:


6) I unchecked 'Keep me subscribed to email notifications' and then clicked 'Install update'.


7) After the 'auto restore' installation was complete I disconnected my phone and followed all prompts. (Make sure you can receive and send emails before you continue).


I then looked for the AW icon but this time it was not there!!! Normally this 'auto restore' resolved the 'non responsive click issue' but today it did not.


8) I decided to delete the just installed AW version and then reinstalled it. Alas, finally the AW icon appeared and now it was responsive.


I followed the phone's prompts, installed my ID and then initialized my paid apps. It is important to do it in this order (install the ID first) or the paid apps will not work properly.


This 'Update' path method  which leads later to the 'auto restore' resolved my issues and all was good again. 


Note: If you have a large music library on your phone as I have make sure it has stopped loading all files before you try to start your ID installation or you get some 'unwanted' messages.


While KB29422  suggests to install App World to avoid the 'no show icon issue' I found that the 'auto restore’ method was always a good work around for either issue to have the latest AW version on my phone.


So this is my today's story which I wanted to share with the community. It might give you some new ideas to try out. I you liked it click either the 'thumb up' or ‘Like button' in the thread. Thx.