Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® OS Smartphones

New Contributor
Posts: 4
Registered: ‎10-08-2012
My Device: 9860
My Carrier: AIS Thailand

BB I'd needs to be verified error on new torch

I recently purchased a 9680 and used my previous BB I D for a few weeks. Now I cannot log into app world, protect or anything that needs the BB I D on the phone. Error message says cannot login at this time and on the login screen it says I D needs to be verified. I've tried new passwords, reinstalling app world, hard reset but no good. I can log in on the pc and attach my phone and it shows it aand all of the apps I have as uninstalled, even though they are still working and installed on the phone. Any ideas?
Posts: 3,246
Registered: ‎07-26-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: BB I'd needs to be verified error on new torch

Hello davidfiges and welcome to the BlackBerry® Support Community Forums.


Sorry to hear you are having issues with your BlackBerry® ID.


KB28212 addresses the error message you are receiving when you go to log in.


Let me know if the error persists after following the aforementioned article.





Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!